Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
lmcrane
Newbie

Good Omens only in Italian

Good Omens is only playing Italian on Prime using Roku.  English everywhere else.  It doesn't give me an English option and when I click on English cc, it doesn't even switch to that.  It's stuck somehow. I think a couple other shows are doing the same bur I don't know their original language so not sure.  For example, The Lake (which I clicked just to check the language situation) also was only in Italian.

Only on Roku.  Works fine using prime app on phone or computer.

0 Kudos
3 REPLIES 3
RokuCarly
Community Moderator
Community Moderator

Re: Good Omens only in Italian

Hi @lmcrane,

Welcome, and thank you for posting here at the Roku Community!

We appreciate you bringing this to our attention. No worries. We'd be more than willing to find you the best resolution regarding the Good Omens being streamed in Italian.

May we know where you are trying to stream the Good Omens? Is it under The Roku Channel or directly from the Prime app? In addition, would you mind sending us a video of the issue you're referring to so that we may be able to assess your concern better? 

We look forward to your update and are committed to finding a solution for this.

Warm regards,
Carly

Carly Y.
Roku Community Moderator
0 Kudos
lmcrane
Newbie

Re: Good Omens only in Italian

I don't have the option to attach a video to this message.

It is happening on the prime channel, but only when I use the roku stick. it is fine in the prime video app and on my desktop.

Audio is only in Italian.  When I click on the language tab right above the play bar it only has Italiano as an option.  When I click on subtitles and "english" it doesn't stick.

I have watched a couple of Italian shows on Netflix with English cc for fun, to improve my Italian, but rarely, and my default language is English across the board.

I made a video but not sure how to include it here.

0 Kudos
RokuJohnB
Community Moderator
Community Moderator

Re: Good Omens only in Italian

Hi @lmcrane,

Thanks for keeping us posted!

Please be advised that for some service providers, closed captions are activated from within the channel. The closed captioning settings available on your Roku streaming device have no effect on the content of these service providers. We have no control over the programming or operation of the channel. We recommend contacting the affected channel's support team to report the issue and for further help.

Please keep us posted if there's anything else we can do to help you.

All the best,

John

John
Roku Community Moderator
0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.