Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Channel Surfer

Roku Streaming Stick+ | 3810X | 11.0.0 - Build 4168-50 | Audio Issues

I have the following set-up

Roku Streaming Stick+ ==> Yahama RX-V385 ==> LG Signage TV 50US340C0UD

I have HDMI-ARC enabled and this set-up has been working well between the last quarter of 2021 and possibly Jan 2022. 

Uniqueness about the environment --

  • I have 3 Roku voice remotes, each with the option to change volume and mute/unmute and turn TV ON/OFF
  • I also have a [spare] Roku Express 4k+ 
  • 50US340C0UD is a SIGNAGE TV that's not connected to the internet , while there is an ethernet port, and while the device does have WEBOS installed, the only way that the TV can be updated/upgraded is by a USB stick. There is no WIFI connection option, no applications installed on the TV ( apps cannot be installed)
    There is NO AUTO-UPDATE or OTA Update for signage TVs

  • The Yahama RX-V385 is not connected to the internet (don't even think can be connected to the internet). I only use it as I have 5.1 Audio system at home.


Issue Description:
Since Jan 2022, I have been having issues, where the audio from my TV seems to change output from HDMI-ARC to TV Output and then back to HDMI-ARC randomly. Sometimes the switch happens within seconds and sometimes, it can take over a minute. This is very very annoying, as the audio fidelity is lost and also volume suddenly changes.

It seems to happen much less ( not happen)  on Prime Video, but seems to happen on the following apps

  1. HBO MAX
  6. HULU
  7. possibly More


  1. Another thing I have noticed is that while I have 3 remotes, if two remotes are not paired, but have 'batteries' in them, they seem to get paired automatically. I have been able to reproduce this issue multiple times.
    Initially, I thought that one of the remotes must have been bad, and may have a depressed button or something, but after hours of removing the pairing from all remotes and just having one remote paired and using for a couple of days, I have concluded that my remote isn't an issue.

  2. One thing I also noticed is that HDMI-CEC is enabled on my TV, and when I use the Streaming Stick+, and use a[ny] remote, and press the mute button quickly twice, it seems to bring up LG accessibility menu. However, the same set-up doesn't bring up the menu when using Express 4k+.
    I also noticed that the Streaming Stick+ used to provide metadata like Dolby Audio to my AV Receiver Yamaha RX-V385, however, now I just see H:2 or PCM. Switching to Express 4K+, I see DD+

Testing Complete

  • I have tried to re-configure the equipment, to allow my ROKU to be connected directly to my TV, and then use HDMI-ARC but the issue with my streaming stick+ continues but haven't seen any change in behavior
  • I have replaced the HDMI cable, thinking that the cable may have been faulty ( or generated a fault over the years)
  • Factory reset the Streaming Stick+ ( issue can be seen within 5 minutes)
  • [numerous times] Factory reset my signage TV and Yahama RX-V385 receiver


Thank you for reading the lost post.

I don't think that the issue started with Roku OS 11, but I could be wrong. Given auto-update, I haven't kept a track of the version(s) installed

0 Kudos
Community Streaming Expert

Re: Roku Streaming Stick+ | 3810X | 11.0.0 - Build 4168-50 | Audio Issues

Tagging @RokuDanny-R 

Roku Community Streaming Expert
Note: I am not a Roku employee.

If this post solves your problem please help others find this answer and click "Accept as Solution."

0 Kudos
Roku Guru

Re: Roku Streaming Stick+ | 3810X | 11.0.0 - Build 4168-50 | Audio Issues


1) You can check the date the firmware was installed/updated:  Settings/System/System update/Last updated

2)  There is an issue with *ALL* remotes (LG/Roku/other) when programmed with certain LG TV IR codes:  Quickly double-muting causes an A/V Settings Reset menu (older NetCast models) or mini Service Menu (including A/V reset - Newer WebOS models).  This is not a Roku-related bug, but an LG IR code bug (you can replicate it with any LG/LG programmed remote).  CEC is not the problem here, IR code usage is (your TV/Roku w/CEC-enabled doesnt cause/enable it).

3) For the SS+ "missing" Dolby output verify

   A) Settings/Audio/Streaming audio format = Auto

        Settings/Audio/Digital output format = Auto

   B) When Digital output format/Auto is HIGHLIGHTED that a Dolby format is detected (if no Dolby mode is listed than you wont get Dolby/5.1)

   C) Volume/Sound modes are DISABLED (if enabled you wont get 5.1 output):  During playback, press Options (*)/Volume mode = Off

Channel Surfer

Re: Roku Streaming Stick+ | 3810X | 11.0.0 - Build 4168-50 | Audio Issues

@user  Thank you for the information. What's interesting really is that the same remote when used in conjuction with Exress 4K+ doesn't exhibit the issue with the same LG TV. Now I understand how IR would work with the TV, but it seems that when used successively twice, the Streaming Stick+ is sending a signal to the TV.

I find it hard to find that the same remote, the same TV combination has issues when using Streaming Stick+ but NOT when using Express 4K+

The firmware mentioned on the subject line is what was last updated, I would say 1 week ago. I have consistenly tried to update the system over the last couple of months everytime before reproducing the issue. The last time I tried is when I created this thread ( less than a couple days ago).

For DD+, I have tried to change to Auto and also Manual config, but the issue DOESN'T resolve. 

0 Kudos
Roku Guru

Re: Roku Streaming Stick+ | 3810X | 11.0.0 - Build 4168-50 | Audio Issues


1) Again, the "open service menu for LG TVs with two quick mutes" bug isnt with your Roku remotes, how the remotes are programmed, or whether/how the Roku is using CEC/IR - this is a known "IR bug" with LG TVs, and can be seen/experienced/noticed with ANY/ALL LG TV programmed remotes, be they from Roku or others.

2) The RC-406/RC-AL7 remote from a SS+/3810 paired with an Express 4K+/3941 causes the exact same behavior with LG TVs:  quick double mute causes service menu popup.   As to why your remote isnt exhibiting the same behavior may have to do with its firmware level/specific IR/CEC configuration, or you just werent "patient" enough (it doesnt always do it, sometimes it requires multiple double presses to cause the menu popup behavior).  Regardless of the inconsistent "mute popup" behavior you are experiencing with your Roku remote, its still an LG TV-based bug/issue.

3) You werent being asked for your firmware version, you were being provided a means of checking WHEN your firmware updated/upgraded

Again, you can know the exact date/time of when your RokuOS firmware upgraded by going to Settings/System/System update and checking "Last updated: " - that indicates the exact date/time of the last firmware update, so you dont have to "guess" or "wonder".

4) Its entirely possible the OS11 update caused audio output issues for your SS+/3810 - OS11 actually changes/removes audio settings for most models (including the SS+) and this may be the source of your issue.  You may be able to resolve this several ways:

A) Wait for a newer (likely 417x) build of OS11 that may or may not fix the issue.

B) Factory Reset is known to correct (missing Dolby) audio issues after OS upgrades:  Settings/System/Advanced system settings/Factory Reset

0 Kudos