Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JTBAMA24
Newbie

Ordered a Movie. Won't get go past 99%

Hello, I ordered a 4K Movie on my TCL 5 Series TV last night and it will not play at all. It goes all the way up to 99% and then idles until my TV goes into hibernation mode. SHould I have stuck with HD? Has anyone had this happend? I turned TV off and restarted and nothing.

Thanks,

TA

0 Kudos
1 REPLY 1
Anonymous
Not applicable

Re: Ordered a Movie. Won't get go past 99%

Hi @JTBAMA24

Welcome to the Roku Community!

May we know if are you using a Roku device or Roku TV? On which channel have you ordered the movie? Have you tried removing the affected channel and then re-install it again? If not, we suggest starting there. In some cases, removing the affected channel and then re-installing it may help. Restart your device before re-adding the channel back in to ensure the process is successful. We recommend doing this through the Settings menu by navigating to Settings > System > Power (If there is no Power submenu, proceed to the next step.) > System restart.

For detailed instructions, refer to this Support link for more information: How to resolve a channel playback issue | Official Roku Support.

With more detailed information, we will be able to assist you further.


Warm Regards,
Lianna

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.