Solving playback issues

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Lost 5.1 Dolby Digital Surround on 3920X

This used to work for all my streaming services and now none of them will play with DD.  I'm not sure exactly when it stopped working, but perhaps with the 11.5.0 build.

I have tried all combinations of audio settings and none have helped.


11.5.0 * build 4312-91

Please help.  The ONLY reason I bought a Roku is to stream with 5.1 surround sound and it has worked great for several years, but now that no longer functions.

Thank you.

Labels (2)
0 Kudos
Roku Employee
Roku Employee

Re: Lost 5.1 Dolby Digital Surround on 3920X

Hi @cygnus2048 

Thanks for posting in the Roku Community regarding the issue you are experiencing with the loss of 5.1 Dolby Digital on your Roku device.

We would be more than happy to look further into the issue, but will need more details. What devices are you connecting with your home setup? Is the Roku device connected to your AVR or is connected directly to your TV? Have you tried switching out the HDMI cable used to connect the Roku device. In addition, what channel and content are you seeing this issue occur with? 

For more information about how to properly connect your Roku device for surround sound, visit our Support page here: Set up your player for surround sound

With more information, we will be able to assist you further. We look forward to hearing back from you.


Danny R.
Roku Community Moderator
0 Kudos
Level 7

Re: Lost 5.1 Dolby Digital Surround on 3920X

Ok, so short answer is I was able to fix this and this can be closed.  The long answer is that I did read about a "volume mode" setting and turning that off.  I searched all over through all the settings and could not find that setting.  Since my original post, however, I found *that* setting shows up when you press the asterisk while in any streaming app.   Evidently the new firmware, which added that setting also set the default to "on", which killed all my 5.1 surround.  After turning that off all my 5.1 is back.  If any devs look read this post, I ask then when adding new settings such as this, how about set the default to the OLD way as to not cause issues such as this and hours of my life wasted trying to troubleshoot.

0 Kudos