Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Streaming Star

How to prevent HDMI handshake issues, when Roku is "always on"

My setup is Roku ultra into Onkyo receiver into Vizio TV. All connected through HDMI. Occasionally the screen will go blank for a couple seconds, then come back. I'm pretty sure it's an HDMI handshake issue as I had similar problems with other media players and a Denon receiver. This is solvable by making sure the Roku is the last thing powered on. TV first, then receiver, then Roku. 

But the Roku never actually powers off as far as I know... It's forever in standby mode, so I can't time the power on events with my remote. So to fix it... I unplug the Roku, then power everything on in order. It's a pain. 

Does anyone know a way to solve this?

As a last resort, I could go Roku into TV, TV optical to Onkyo, but Ive had some audio transcoding issues when I go through the TV, which is why I bought the Onkyo, so I could have direct HDMI.

Btw.. they are all new, high speed HDMI cables.



0 Kudos
Retired Moderator

Re: How to prevent HDMI handshake issues, when Roku is "always on"

Hi @sakendrick

Thanks for getting in contact.

Roku streaming players are low-power devices that are designed to remain on and always connected to the internet. There is no “power button” to press on or off. This easy-to-use design prevents confusion by enabling instant access to your player any time you turn on your TV or switch from another source (e.g., cable box, Blu-ray™ player, gaming console).

For more information, visit our Support page here: Can I power my Roku streaming player on or off?

We can also see that you have set up your Roku Ultra to your surround sound, if you need additional information and troubleshooting tips, you might find this topic helpful: How to set up your Roku® streaming player for surround sound

Does this help? Keep us posted. 


0 Kudos
Community Streaming Expert

Re: How to prevent HDMI handshake issues, when Roku is "always on"


Under "Settings > System > Advanced system Settings > Advanced display settings" some Roku devices have an "Auto-adjust display refresh rate" item. 

If this is enabled, the Roku circuitry sends the signal output at the refresh rate (frame rate) used by the original source material, commonly 24 fps (frames per second), 25 fps, 30 fps, 50 fps, or 60 fps. Every time the source frame rate changes, the TV must adjust its display to accommodate the new frame rate, which on many sets results in a short blackout.

This can happen when starting/stopping new programs, and when going in/out of commercial breaks that have a different native frame rate than the programs they are inserted into.

If "Auto-adjust display refresh rate" is set OFF, a frame rate of 60 fps is used for everything and the TV doesn't have to adjust on the fly.

The tradeoff here is that movement of things on the screen for non-60 fps sources may not be as smooth with no frame rate adjustment.  You have to decide whether this change is worth it to you.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos
Streaming Star

Re: How to prevent HDMI handshake issues, when Roku is "always on"

thanks for the response but this is happening mid program - if it was only during breaks for ads or changing programs, I would be less concerned. Screen goes blank, sound keeps on playing. Classic HDMI handshake symptom. And like I said... unplugging the roku so I can power things up in order seems to resolve it. I'll see if by chance my Onkyo has a powered AC outlet - and if so, that might resolve it.

0 Kudos