Roku setup

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mvhetes
Level 7

Roku Ultra will not remain off, but turn on without action by me

Jump to solution

I don't want to use the Roku remote at all times, but it seems that the default is for such to be the case. The player will initially turn off when I push the power key, but a minute or two later will turn itself back on. (I can see this by the power light.)

The TV will remain off, but the device will reboot. I would prefer having total control over when the unit powers up. There are times when I will be using another imput.

What "settings" do I need to address to make this so?

0 Kudos
1 Solution

Accepted Solutions
renojim
Community Streaming Expert

Re: Roku Ultra will not remain off, but turn on without action by me

Jump to solution

Roku devices don't turn off. The power button on the remote is strictly for the TV. At most, Roku devices go into a "power saving" mode that saves very little power and they don't use much to start with. The most recent update (11.5) seems to have messed up the light and I'm not sure it's a reliable indication of anything. If the light being on bothers you disable "power saving" under Settings->System->Power and the light should go off when the screensaver activates.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.

View solution in original post

1 REPLY 1
renojim
Community Streaming Expert

Re: Roku Ultra will not remain off, but turn on without action by me

Jump to solution

Roku devices don't turn off. The power button on the remote is strictly for the TV. At most, Roku devices go into a "power saving" mode that saves very little power and they don't use much to start with. The most recent update (11.5) seems to have messed up the light and I'm not sure it's a reliable indication of anything. If the light being on bothers you disable "power saving" under Settings->System->Power and the light should go off when the screensaver activates.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.