Roku Direct Publisher

The easiest way to create a great TV experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
strangerx
Level 7

Videos show up in search, but not on main screen/categories

Hello. My feed status shows all 4 items that I have uploaded were ingested successfully, but the main screen for my channel only shows the Search and Info buttons - no videos. The videos can be found in search, so I know they are there.

Is this an issue with my categories? I am using RDP and WP Smart TV plugin for Wordpress and initially created categories using WP Smart TV Plugin ("from feed"), but when that didn't work I switched to RDP categories, and now I'm back to WP Smart TV Plugin because RDP categories did not work. 

 

Help!

0 Kudos
7 Replies
AaronMSpelling
Level 12

Re: Videos show up in search, but not on main screen/categories

hi @strangerx  if you look in the forum you will see some other posts with the same issue , it's a Roku bug easily fixed by the Roku Dev Support : https://developer.roku.com/contact

Building a TV Channel can be easy … if you have a right tools ===>> https://tv-channel.info/
TSC850
Level 7

Re: Videos show up in search, but not on main screen/categories

We are also experiencing vanishing content. Videos that are in our feed and have been ingested by Roku Direct Publisher are not showing in channel. Feed checks out. Categories check out. Don't think it's related to Roku content limits. Are you able to please expand on the Roku bug comment? Do you have any details? I've submitted a Roku Dev Support ticket, but if there's anything we can do to fix it on our end, we would like to try. BTW - We own six channels and it's happening to some degree on all of them. Some worse than others. Seems to have started a few weeks ago and is gradually getting worse. We are unable to pull up those missing videos in search (tried it after reading OP's comment) Thanks!

0 Kudos
AaronMSpelling
Level 12

Re: Videos show up in search, but not on main screen/categories

@TSC850  nop no explanation  , just "it is a small bug in the system"  sometime works sometime ......  not really. 

the only thing you can do is to make sure that on your end the feed and channel are set up properly , and when you notice that something is wrong on the tv display  ......  well Roku Dev Support is the fastest way to go ...

this is what I do with the channels I have and/ or manage , and always works out at the end.

Building a TV Channel can be easy … if you have a right tools ===>> https://tv-channel.info/
mosafer
Level 10

Re: Videos show up in search, but not on main screen/categories

My experience:

Change your vanished item's ID to the new ID (you never used it before) and wait 24 hours.

It solved my problem.

 

mmattcam
Level 7

Re: Videos show up in search, but not on main screen/categories

Can you explain what you mean by change the vanished items id--having a similar problem

No videos displaying.  All I get when I launch channel is Search/about.  Only one image displays for one of four series.  Click on it and get frozen episode page with no images, no loaded videos.  Other 3 not appearing at al

Feed not refreshing.  Roku doesn't update channel.

Channel (still in preview mode not public yet) was working fine a couple of weeks back.  I'm getting no information from Roku Partner Success,  only two responses to ask a question which I responded to in over a week now.  No recent follow up, no indication of what the issue could be.

0 Kudos
mosafer
Level 10

Re: Videos show up in search, but not on main screen/categories

Each item has an "ID" in your JSON file. just change it to another "unused" ID. I don't know about the unpublished channel, in my experience, it was published.

TSC850
Level 7

Re: Videos show up in search, but not on main screen/categories

Thanks for everyone's suggestions. We've opened a support ticket and are hoping for a resolution that addresses the root cause. Whether its a Roku Direct Publisher bug or an issue on our end. Either way, I will follow up with another post when it gets resolved.

The ID in our JSON feed is created dynamically by our VMS, so not easy to change it manually. But I did confirm with one video.... that deleting the original entry in our VMS and creating a new identical entry (which creates a new ID) did get it to show up again within the channel. (thanks for the tip mosafer!)

So that could be a good temp solution in many cases.

But we manage 6 channels with hundreds of videos each. There are dozens of missing videos, possibly hundreds. We could spend days sorting it out, then have it happen all over again. Not to mention the issues of historical analytics and managing lots of duplicated/unpublished content. We've always had good experiences with Roku dev support, so I'm hoping the support ticket yields some answers.

- Steve

0 Kudos