Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
KevinKillion
Level 7

AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

I was thrilled to learn of the software update, and AirPlay works great on my Roku Ultra 4660.  On the Mac, I direct my music to go to the Roku, and it then plays on the TV connected to the Roku. 

However:  For perhaps 10 minutes, the screen shows the graphic stored in iTunes with each song.  Cool!  But after that, the screen just shows the word "AirPlay" in gray on a black background.  The text moves to different positions as if it were a screen saver of some sort.  If I click most any button on the remote the graphics come back, but it switches to the text again after another 10 minutes.

Any ideas on how to have the graphics continue to show after that 10 minutes?

Tags (2)
13 Replies
martin4
Level 7

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

I agree with this...Have looked all through the settings and can't find anything. Hope that they can either turn this off when something is streaming or make it a user setting. It is annoying to have to hit the OK button every ten minutes to keep the album art up when listening to music or whatever. 

beehaze
Level 7

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

Same issue here. Might be a dealbreaker for me — AirPlay was a primary reason for choosing the Roku, but this “screensaver” is awful. The software should keep the “Now Playing” screen updated during playback. 

ytang
Level 7

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

Try disabling screensaver if you want the TV to be on all the time.

The option is under Settings -> Theme -> screen saver wait time 

jbtchr
Level 7

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

The disable screensaver suggestion worked. Thanks!

0 Kudos
tabethalyn
Level 7

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

Disabling the screen saver option works for me as well! 

0 Kudos
sg23
Level 8

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

Actually, disabling the screensaver entirely is not very practical as some would like to keep it on for most of the other apps. Ideally, the Roku would recognize that the app is active if music is playing.

martin4
Level 7

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

Totally agree. I like the screen saver generally and should not have to disable to get album art to consistently display while streaming music. Expected functionality IMHO. 

StreamerUser
Community Streaming Expert

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

This AirPlay screensaver behavior is controlled by the AirPlay app (AirPlay is a hidden set of apps) - since Apple codes the app, Apple is the one that needs to change/modify the screensaver behavior while AirPlay is in use.

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
tabethalyn
Level 7

Re: AirPlay is GREAT! BUT song pix give way to just "AirPlay" text

I turned off my roku screensaver settings and it removed the Airplay screensaver so my issue was resolved! 

0 Kudos