Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
infinite1
Level 7

rowList focus jumping to the 0th element

I'm using a Roku "RowList" and whenever I have additional rows to the RowList content the "focusBitmap" and the rowList focus is jumping to the 0th element of the currently focused row every time a new row of content is added to the rowList. This rowList bug seems to be happening when a rowList is being scrolled and content is being added in the background by the Task Node.

0 Kudos
2 Replies
chaklasiyanikun
Level 11

Re: rowList focus jumping to the 0th element

I don't really understand the question. I think you are said the focus is jumping to the 0th element if RowList content is load. right? I think your RowList content and FocusBitMap both are in space. please refer https://community.roku.com/t5/Roku-Developer-Program/Rowlist-focusBitmapUri-offset-on-first-focus/td...

0 Kudos
infinite1
Level 7

Re: rowList focus jumping to the 0th element

Thanks for replying!  To sum up my problem in more detail ... This rowList bug seems to be happening when a rowList is being scrolled and content is being added in the background by the Task Node. I'm using roku "RowList" and whenever I have additional rows to the RowList content the "focusBitmap" and the rowList focus is jumping to the 0th element of the currently focused row every time a new row of content is added to the rowList. If you are pushing down on the remote while autoloading is happening the selector glitches while the autoloading from the API is happening. After autoloading is completed from the API for all posters (their are many) I can scroll with no issue and the selector isn't jumping around and glitching.  Here i something else: If I switch to the way Netflix displays the rows using fixedFocus the glitch is gone.

0 Kudos