Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 10

my.roku.com/add bug: wrong diagnostic

I guess it was too soon to celebrate my.roku.com/add/code as working. See the snapshot below.


Note that what the red box says is incorrect - the channel code is valid and associated with a working channel.

Can you figure out what's wrong, what was the real reason to decline installing the channel?

I wish i had some trophy/keepsake to give away, since guessing the cause might be tough. Still, will be a good brain teaser. Anybody want to give it a shot?
0 Kudos
6 Replies
Highlighted
Level 7

Re: my.roku.com/add bug: wrong diagnostic

When I got to https://my.roku.com/add/agario I get 302 redirected to https://my.roku.com/account/add?channel=agario

And see this:
0 Kudos
Highlighted
Level 10

Re: my.roku.com/add bug: wrong diagnostic

"BCVatOVG" wrote:
When I got to https://my.roku.com/add/agario I get 302 redirected to https://my.roku.com/account/add?channel=agario
[spoiler=And see this:qkaroxky][/spoiler:qkaroxky]

Yeah, that's how it works - when it works. Some accounts however would instead see the red message
"The channel code provided is not associated with a valid channel."
What i am hinting is if even experienced software developers can't guess the reason, that message is a bug and should be corrected Smiley Wink
0 Kudos
Highlighted
Level 7

Re: my.roku.com/add bug: wrong diagnostic

"EnTerr" wrote:
"BCVatOVG" wrote:
When I got to https://my.roku.com/add/agario I get 302 redirected to https://my.roku.com/account/add?channel=agario
[spoiler=And see this:2fwmk6nm][/spoiler:2fwmk6nm]

Yeah, that's how it works - when it works. Some accounts however would instead see the red message
"The channel code provided is not associated with a valid channel."
What i am hinting is if even experienced software developers can't guess the reason, that message is a bug and should be corrected Smiley Wink



I had similar problem.
The reason that some of users didn't see my channel was that they were in region that was not select in channel as distribution area.
After adding required regions it started working.
0 Kudos
Highlighted
Level 10

Re: my.roku.com/add bug: wrong diagnostic

"Skrzypu" wrote:
I had similar problem. The reason that some of users didn't see my channel was that they were in region that was not select in channel as distribution area. After adding required regions it started working.

Oh? That's different from the exact reason in my case - but a totally valid answer.

So if for some reason - any reason at all - it cannot add the channel, it shows the bogus message above. And it is not that it cannot actually tell the reason - because if using the "old" site owner.roku.com/add/code - it actually shows a correct explanation.
[spoiler=spoiler:1tslqkw1][/spoiler:1tslqkw1]
@Roku* - can we haz regression bug filed on this thing, please?
0 Kudos
Highlighted
Level 10

Re: my.roku.com/add bug: wrong diagnostic

@Roku* -
did someone enter bug on this?

It's been couple of months and the issue is still there.
0 Kudos
Highlighted
Level 10

Re: my.roku.com/add bug: wrong diagnostic

@RokuBueller ? Smiley Wink
0 Kudos