Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 

ads playing from non-US locations

I have noticed that ads play only when the viewers are within the U.S. Ads go unfilled in Europe, South America, and even Canada. Can anyone recommend a company that can fill ads when the viewers are in other countries? 
0 Kudos
5 Replies
EnTerr
Level 8

Re: ads playing from non-US locations

Just to clarify, i presume you mean you are using RAF library and serving ads from Roku's own inventory?
And you are finding out there is lack of ad supply from abroad. I too observed that when trying to figure out why roughly 1/3 of my ad requests were failing - and when i checked IP geolocation, many of these IPs were from outside USA.
0 Kudos
renojim
Level 8

Re: ads playing from non-US locations

I believe if you're using Roku to fill your ads you won't get any for non-US based devices.  I vaguely recall an email conversation I had stating something to that effect due to contractual obligations, but it would be nice to hear from someone at Roku.  It always made me wonder how my games perform outside the U.S. with respect to what happens at ad-time, but I never wanted to go through the bother of setting up a VPN to find out.  I assume since I'm not seeing any (or, uh... many) crashes, everything must be ok.  I just went through all my crash logs and the very few crashes that I've had all occur within roku_ads_lib, although I don't believe they're related to this issue.

-JT
0 Kudos
EnTerr
Level 8

Re: ads playing from non-US locations

"renojim" wrote:
 I just went through all my crash logs and the very few crashes that I've had all occur within roku_ads_lib, although I don't believe they're related to this issue.

Do you by any chance have the file name and line number where that happens? It could help the Co troubleshoot, gott willing...
0 Kudos
renojim
Level 8

Re: ads playing from non-US locations

Function $anon(config_ As Dynamic) As Void; file/line: roku_ads_lib:/Roku_Ads_BrightLine.brs(5232)
Function $anon() As Boolean; file/line: roku_ads_lib:/Roku_Ads_Innovid_iRoll.brs(10294)


Does anyone else find the "Manage My Channels" section incredibly frustrating to use?  Forward/Backward a page don't work properly (when I right click the "Go back one page" control in Firefox all I get is "R Roku" listed over and over and going back from the details of a channel takes me back to the top of my list of channels; it's a pain to get back to where I was).  Sometimes hovering over text will change the cursor making it appear that it's a link, but it's not, like in the crash log (I had to inspect the element just to copy that text; seen this within the documentation as well).  Sometimes clicking on the "Crash Logs" shows the log, other times it shows nothing.  Is it me?  My browser?  Just another example of the fine work of the Roku web design team?

-JT
0 Kudos
EnTerr
Level 8

Re: ads playing from non-US locations

"renojim" wrote:
Does anyone else find the "Manage My Channels" section incredibly frustrating to use?  Forward/Backward a page don't work properly (when I right click the "Go back one page" control in Firefox all I get is "R Roku" listed over and over and going back from the details of a channel takes me back to the top of my list of channels; it's a pain to get back to where I was).  Sometimes hovering over text will change the cursor making it appear that it's a link, but it's not, like in the crash log (I had to inspect the element just to copy that text; seen this within the documentation as well).  Sometimes clicking on the "Crash Logs" shows the log, other times it shows nothing.  Is it me?  My browser?  Just another example of the fine work of the Roku web design team?

Hmm, seems that corner hasn't seen a QA in years? 
Can you enter these as issues in https://github.com/rokudev/docs/issues ? (We had some success there, the portal bugs posted in the fall got fixed) On your side, experiment opening FF in incognito mode and w/o plugins. Does it also happen in another browser?
0 Kudos