Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
greid
Level 7

Re: Telnet to 8080 fails (8085 works fine)

That was a great suggestion, malloys. Windows 7 had the same problem (perhaps because it was running inside Parallels on my Mac), but my Android tablet was able to telnet successfully to the Roku and run genkey!

I am still mystified as to why it doesn't work from the Mac, when port 8085 works fine. Port 8080 is used for a lot of web stuff (since it's similar to port 80 which is http) so it seems like a poor choice for Roku to listen on, given various other things competing for that port, which presumably is/was the problem, although I never found anything blocking 8080 or listening on it or otherwise interfering.

Harumph. I still think that genkey should be a web service in the Developer section, not somehow associated with a particular piece of Roku hardware. Put that in the Suggestion box.

In any case, I seem to now have the required generated key and packaged application, so I'm making some progresss again, finally. Thanks to all who responded!!
0 Kudos
RokuJoel
Roku Employee
Roku Employee

Re: Telnet to 8080 fails (8085 works fine)

Something is definitely up on your mac. Sometimes mac firewall configuration can become corrupt (in my experience). Might consider a completely fresh install of OS X.

- Joel
0 Kudos
pwenzel
Level 7

Re: Telnet to 8080 fails (8085 works fine)

"greid" wrote:
This is puzzling... I have been happily telnetting to port 8085 (debug) on my Roku, but cannot connect successfully at all on port 8080 (to run genkey). I've tried everything I can think of. It connects immediately, but no matter what I type, it drops the connection as soon as I hit return.

Has this happened to anybody else?


I have the same problem and it is absolutely crazy making. Telnetting to a Roku on port 8080 from Mac OSX (Mavericks here) fails completely. However, telnetting from a Windows XP machine on the same network runs fine.

I have replicated the problem on newer Roku and an older Roku (several years old) and two different Macs. I have even replicated the problem in multiple networks and routers. This problem makes running `genkey` pretty cumbersome if you do any development on OSX.

I speculate that something is up with my Terminal's emulation settings, but I can't figure out what it is yet.
0 Kudos
RokuMarkn
Level 8

Re: Telnet to 8080 fails (8085 works fine)

I just tried running telnet from an older Mac running 10.6.8 and it worked fine. All default terminal settings as far as I know.

--Mark
0 Kudos
squirreltown
Level 9

Re: Telnet to 8080 fails (8085 works fine)

I run 10.6.8 on an original MacPro, no such problems.
Kinetics Screensavers
0 Kudos
EnTerr
Level 11

Re: Telnet to 8080 fails (8085 works fine)

"pwenzel" wrote:
I have the same problem and it is absolutely crazy making. Telnetting to a Roku on port 8080 from Mac OSX (Mavericks here) fails completely. However, telnetting from a Windows XP machine on the same network runs fine.

I have replicated the problem on newer Roku and an older Roku (several years old) and two different Macs. I have even replicated the problem in multiple networks and routers. This problem makes running `genkey` pretty cumbersome if you do any development on OSX.

I speculate that something is up with my Terminal's emulation settings, but I can't figure out what it is yet.

Since you have tried multiple Rokus and routers, seems issue is in the particular Mac you are using. Continuing divide&conquer, try "ncat ROKU-IP 8080" and that will tell you whether to blame terminal in particular.

ps. Do you have any VPN client or firewall exotics on the Mac? Anything interesting in "sudo ipfw show"?
0 Kudos
panzhuli
Level 7

Re: Telnet to 8080 fails (8085 works fine)

I have this same problem on my Mavericks machine. I've even moved to a different office and it seems like something unique to using a Mac
0 Kudos
squirreltown
Level 9

Re: Telnet to 8080 fails (8085 works fine)

"panzhuli" wrote:
I have this same problem on my Mavericks machine. I've even moved to a different office and it seems like something unique to using a Mac

Nope. Telnet 8080 every day on my Mac but its running Snow Leopard.
Kinetics Screensavers
0 Kudos
RokuJoel
Roku Employee
Roku Employee

Re: Telnet to 8080 fails (8085 works fine)

Hate to resurrect a dead thread, but we encountered this in the office today and tracked it down to the Cisco Anyconnect VPN client for OS X, which once removed resolved the problem, so for anyone who encounters this, that should be on your list of things to check for.

- Joel
0 Kudos
EnTerr
Level 11

Re: Telnet to 8080 fails (8085 works fine)

"RokuJoel" wrote:
Hate to resurrect a dead thread, but we encountered this in the office today and tracked it down...

Oh no, by all means - please do. Thread was not dead, just dormant - but today or yesterday i saw Greubel mention in passing in another thread that telnet to 8080 did not work on Mac. One more "cold case" seems to be solved...
0 Kudos