Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8

Subtitles not working on resumed play

When playing titles from Plex.

Sustitles stop working when resuming playback.

If I watch a movie from start to finish, there usually and no issues with subtitles, however when I watch half a movie via Plex, say, watch half the movie today and resume playiong to the mvive the following day, the subitles work for 10 - 15 15 seconds or so and then they quit.

the Plex server is running off my computer with a wireless connection to the Roku. Wireless connection shows as "Good".

Any ideas why the subtitles stop or how I can fix the issue?

4 Replies
Highlighted
Level 7

Re: Subtitles not working on resumed play

Same issue with me. Drives me nuts.

0 Kudos
Highlighted
Level 8

Re: Subtitles not working on resumed play

Seems to be an issue with .srt files. .PGS files seems to resume okay.

 

0 Kudos
Highlighted
Level 7

Re: Subtitles not working on resumed play

I'm using MKV files with imbedded subtitles. Seems to resume for up to a minute before they drop out.

0 Kudos
Highlighted
Level 8

Re: Subtitles not working on resumed play

Yes, same here. I've tried a few things but no luck.

  1. Marked the movie as played and then FF to resume point
  2. Power cycled the Roku
  3. Turned the CC off, played movie for a few moments and then turned CC back on.

Also another glitch. When resuming after a day, the movie stops at around the last 2 minutes. Not an issue on later movies where you have 10 minutes of credits, but a real pain in the arse when it’s an older movie with very short credits at the end.

 

 

0 Kudos