Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
joetesta
Level 10

Strange behavior with Screenshot button

Working on a yet-to-be-released application, and taking some screenshots.  For a remote colleague on RokuTV, clicking the screenshot button is triggering navigation!?!  This is preventing the screenshotting of the desired state.
For me on Roku 3, clicking the screenshot button triggers a "flash" on the screen that I don't recall ever noticing in the past.
aspiring
0 Kudos
11 Replies
Roku Employee
Roku Employee

Re: Strange behavior with Screenshot button

Would you kindly provide the model# and firmware# where this is happening?
0 Kudos
squirreltown
Level 9

Re: Strange behavior with Screenshot button

"joetesta" wrote:

For me on Roku 3, clicking the screenshot button triggers a "flash" on the screen that I don't recall ever noticing in the past.

Can't address the RokuTV but Roku 3's (42xx) currently have a firmware problem that might cause that, and has been identified already.
Kinetics Screensavers
0 Kudos
Komag
Level 9

Re: Strange behavior with Screenshot button

My Roku 3 will blink away whatever is the last thing drawn for a moment, but it still shows up in the screenshot, so it's not a problem.
4200X, 7.6.0 build 4125-04

Roku Stick blinking out much more than Roku 3, but again it's still showing up in the shot.
3600X, 7.6.0 build 4125-24

I got no blink of any kind on Roku 4, working flawlessly
4400X, 7.6.0 build 4120-17

On my Roku 1 I got very terrible results! Whole bar sections of graphics are missing, sliced out with reckless abandon, yuck! The game was almost going in slow motion while the shot was processing, and the number of black bar sections seems to coincide with the number of pauses I could notice. I then switched the screenshot format to png, and it got even worse. There were more pauses because the processing time was longer, and there were correspondingly more black bar areas.
2710X, 7.6.0 build 4120-06


My Roku Express+ working flawlessly, no blink or anything
3710X, 7.6.0 build 4120-28

My Roku 2XS working flawlessly, no blink
3100X, 7.6.0 build 4125-02

My Roku TV wouldn't take screenshots at all, no luck! I tried jpg and png, nothing. I didn't get any other side effects, just no pic (and no single pause in-game like all the rest did when taking a pic)
5120X, 7.6.0 build 4127-08

Untested - old Roku Stick
0 Kudos
Roku Employee
Roku Employee

Re: Strange behavior with Screenshot button

Komag -
thank you for the details. A simple test by me on Roku 3 did not show the problem, seems "there is more to it" - do you have observations where it does and does not happen? E.g. does it happen only with roScreen?

Also, someone that can repro the problem on 7.6 and has access to the next beta - is the issue still there?
0 Kudos
Komag
Level 9

Re: Strange behavior with Screenshot button

My game is roScreen with multiple compositors and draw calls. The blink thing does not cause a problem though.

Also, tested my older Roku Stick, works correctly without any issues at all
3500X, 7.6.0, build 4125-09
0 Kudos
necrotek
Level 7

Re: Strange behavior with Screenshot button

Komag,

I have had this issue with roScreen.  Best fix is to halt the program where you would like to take a screenshot by 'control+c' in the terminal debug window or place a 'STOP' in the code where you would like to take a screen shot. Since there will be no swap buffer, there will be no black lines.  I have not tested this with other components since I only use roScreen 
0 Kudos
Roku Employee
Roku Employee

Re: Strange behavior with Screenshot button

"joetesta" wrote:
Working on a yet-to-be-released application, and taking some screenshots.  For a remote colleague on RokuTV, clicking the screenshot button is triggering navigation!?!  This is preventing the screenshotting of the desired state.
For me on Roku 3, clicking the screenshot button triggers a "flash" on the screen that I don't recall ever noticing in the past.

@OP joetesta - chip in Smiley Happy with more info, pls. What's the RokuTV model#, what firmware is it running and in what kind of screen is this happening (roSgScreen/RSG? roScreen?)
0 Kudos
joetesta
Level 10

Re: Strange behavior with Screenshot button

"RokuNB" wrote:
"joetesta" wrote:
Working on a yet-to-be-released application, and taking some screenshots.  For a remote colleague on RokuTV, clicking the screenshot button is triggering navigation!?!  This is preventing the screenshotting of the desired state.
For me on Roku 3, clicking the screenshot button triggers a "flash" on the screen that I don't recall ever noticing in the past.

@OP joetesta - chip in Smiley Happy with more info, pls. What's the RokuTV model#, what firmware is it running and in what kind of screen is this happening (roSgScreen/RSG? roScreen?)

Sorry for my absence from this thread, I haven't been back for a while and just noticed the replies!
This is in roScreen
Roku TV - 5405X
Insignia model NS-32DR310NA17
Software version 7.6.0 build 4127-20
It takes screenshots, but clicking the screenshot button navigates before the shot and therefore not able to capture the desired state on this device.
Let me know if I can provide more info.  Thanks.
aspiring
0 Kudos
Highlighted
RokuMichaelA
Level 7

Re: Strange behavior with Screenshot button

Perhaps see:
https://sdkdocs.roku.com/display/sdkdoc ... hotUtility
If the information is not here that you are looking for, then we will work on adding additional information to this page.

Hope this helps.
0 Kudos