Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
ytsejamdream
Level 7

Setting CaptionStyle

Hi guys,

I'm new over here, I'm having problem setting captionStyle. This is my code:

m.video.globalCaptionMode = "On"
[size=85][font=Monaco]m.video.subtitleTrack = params.subtitlesUrl[/font][/size]
[size=85][font=Monaco]m.video.captionStyle = {[/font][/size]
[size=85][font=Monaco][color=#000000] [/color][color=#3f7777]"Background Color"[/color][color=#000000][color=#000000]: params.[/color][/color][color=#ff9e00][color=#ff9e00]backgroundColor[/color][/color][/font][/size]
[size=85][font=Monaco]    [color=#3f7777]"Background Opacity"[/color]: params.backgroundOpacity[/font][/size]
[size=85][font=Monaco]    [color=#3f7777]"Text style"[/color]: params.textStyle[/font][/size]
[size=85][font=Monaco]    [color=#3f7777]"Text color"[/color]: params.textColor[/font][/size]
[size=85][font=Monaco]    [color=#3f7777]"Text size"[/color]: params.textSize[/font][/size]
[size=85][font=Monaco]    [color=#3f7777]"Text edge effect"[/color]: params.textEdgeEffect[/font][/size]
}


The subtitle is showing but it seems that styles showing are the ones set in the system (default), not the ones that I'm setting in code.
Thanks for your help.
0 Kudos
1 Reply

Re: Setting CaptionStyle

See this thread: https://forums.roku.com/viewtopic.php?f=34&t=116502&p=594780&hilit=captionstyle#p595085
The properties listed in the docs are incorrect. That post has the correct properties.
0 Kudos