Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
monkeysource
Level 7

MarkupGrid firmware 7.5 Issues

We are testing our Channel on firmware 7.5 and are seeing some issues with the grid rendering. We use a MarkupGrid with a flexible layout. It has 15 x 3 layout cells and we utilise the ability for some cells to span rows, resulting in 30 items. During development, targeting 7.2 this approach worked fine. However, while testing on 7.5 I've noticed the cells are not always drawing. 

As an example, I have attached some screenshots, which highlight how some of the cells don't render. If we translate the grid (x-direction) then the cells that don't render change. From testing, it appears to be an issue with the clipping logic as part of the render path of the grid. It feels as though the grid has decided that a cell isn't visible so doesn't waste time painting it. 

As mentioned, this all works fine on 7.2. I have also reduced the code complexity right down so the only thing in the cell is a coloured Rectangle in case the grid item itself was the issue. But as far as I can see it's an issue with the grid layout code. 



Any ideas much appreciated. 
0 Kudos
1 Reply
monkeysource
Level 7

Re: MarkupGrid firmware 7.5 Issues

I've found a workaround for this issue. 

From observation, it is only the bottom row of cells that do not render correctly. Therefore, a hack is to add an invisible row of cells to the bottom of the grid!

For me this meant adding a new row of 0 height cells at the bottom of the grid. Tested on 7.2 (still works fine) and 7.5 and all is working OK.

Hopefully, a fix will come in an update to the SDK but for now at least we can get around it.

Hope this helps someone else.

Thanks,

Ryan
0 Kudos