Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
FxProgrm
Level 8

HLS Stream Tester with Stereo/DD tracks failing to start

I have encoded a title and provided the necessary parameters per the HLS spec on how the audio EXT-X-MEDIA should be named.  When launched, the stream tester starts up but eventually throws a generic 'Video PlayBack Error": An unexpected problem (but not server timeout of HTTP error) has been detected.  Trying to understand how to debug this or capture some more detailed response from the stream tester app.  I presume it's something to do with the DD track, but no idea as to what would be the issue.HLS

Thanks.

Test Device: Roku 3090RW - Roku Express

Software: 10.5.0 4208-AE

HDMI connection to an monitor with internal stereo speakers.

#EXTM3U
#EXT-X-VERSION:4
#EXT-X-INDEPENDENT-SEGMENTS
#EXT-X-STREAM-INF:BANDWIDTH=11332537,AVERAGE-BANDWIDTH=10193732,CODECS="ac-3,avc1.4d4028,mp4a.40.2",RESOLUTION=1920x1080,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_1080_10000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=9161361,AVERAGE-BANDWIDTH=8191521,CODECS="ac-3,avc1.4d4028,mp4a.40.2",RESOLUTION=1920x1080,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_1080_8000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=6978753,AVERAGE-BANDWIDTH=6161648,CODECS="ac-3,avc1.4d4028,mp4a.40.2",RESOLUTION=1280x720,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_720_6000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=4476357,AVERAGE-BANDWIDTH=3710536,CODECS="ac-3,avc1.4d401f,mp4a.40.2",RESOLUTION=960x540,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_540_4000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=2551004,AVERAGE-BANDWIDTH=2198790,CODECS="ac-3,avc1.4d401f,mp4a.40.2",RESOLUTION=854x480,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_480_2000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=1612800,AVERAGE-BANDWIDTH=1269328,CODECS="ac-3,avc1.4d401f,mp4a.40.2",RESOLUTION=640x360,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_360_1200.m3u8
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="program_audio",LANGUAGE="eng",NAME="English",AUTOSELECT=YES,DEFAULT=YES,URI="sample_audio_96_2ch.m3u8"
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="program_audio",LANGUAGE="eng",NAME="English",AUTOSELECT=YES,DEFAULT=NO,URI="sample_audio_384_6ch.m3u8"
#EXT-X-MEDIA:TYPE=SUBTITLES,GROUP-ID="subs",NAME="English",DEFAULT=YES,AUTOSELECT=YES,FORCED=NO,LANGUAGE="eng",URI="sample_cc.m3u8"
0 Kudos
2 REPLIES 2\
renojim
Community Streaming Expert

Re: HLS Stream Tester with Stereo/DD tracks failing to start

Your m3u8 file would be much easier to read if you enclosed it within code tags (the </> button).

Have you tried just testing one stream at a time?

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
FxProgrm
Level 8

Re: HLS Stream Tester with Stereo/DD tracks failing to start

@renojim If I play back the title on a device that supports 5.1 audio (the 2nd audio output) it works fine.  The particular Roku devices I test with are a Roku Ultra (4800) connected to a 5.1 capable receiver, Roku Express (3930) and Streaming Stick+ (3810) connected to a monitor with stereo speakers.

I am not sure what part of the process the express/stick devices are having an issue with causing it to crash.

3810X - 10.5.0 build 4208-50

0 Kudos