Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
DanielRuiz
Level 7

Error -3 on 9.3 OS version

I found that on Roku OS 9.3 the same playback content that I reprodoce on Roku OS 9.2 show an error -3, this error regarding Roku documentation is unknown, and comparing the releases notes (9.2 vs 9.3) I not found some relevant diferences.

Thanks.

0 Kudos
2 Replies
FloSports
Level 7

Re: Error -3 on 9.3 OS version

To restate, we have HLS VOD videos that play fine on 9.2, but fail with unknown error code -3 on 9.3.

 

Here is a spreadsheet with different URL's that work/don't work on 9.2/9.3. They will expire within 24 hours:

 

https://docs.google.com/spreadsheets/d/1CGm-rsPnsFhMLM9COdfEcvGeLDbTfWPvs8hG80MHfok/edit#gid=0

 

Does anyone know why videos would fail on 9.3 but work on 9.2?

0 Kudos
renojim
Community Streaming Expert

Re: Error -3 on 9.3 OS version

You would do better to ask in the developer forum:

https://community.roku.com/t5/Roku-Developer-Program/bd-p/roku-developer-program

That error is CURLE_URL_MALFORMAT, but the URLs look ok to me.  You can see the error list here:

https://developer.roku.com/docs/references/brightscript/events/rourlevent.md

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos