Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
EnTerr
Level 8

Enabling developer mode hangs Roku4 @7.0?

This is bizarre but happened for real and i had to power-cycle a Roku4 a few times. Notice the problem persevered past reboot.

Today i trued to enabled dev.mode/side-loading on a Roku4 (7.0.8863 @ 4400) and
  1. When i clicked on "enable" inside the HHHUURLRLR menu, it popped a caution dialog it will restart and after i okay-ed that, it exited to home menu... except everything was frozen. No audio feedback on remote keys, the locate-remote button on player top has no effect either - i ended up yanking the power cable

  2. (the matrix, reloaded) After restart, HHHUURLRLR again, tried enable again - this time it showed me the SDK click-through agreement and after okay-ing that, immediately it threw me in home menu, frozen again. Power-cycle rinse & repeat followed

  3. (the matrix, revolutions) After restart, HHHUURLRLR again, tried enable again - this time it skipped the legalese page and took me to define a password, after which this time it merrily restarted the player (as expected)

I don't remember ever experiencing that, is this a new development in rOS 7.0?

I am trying to think of what was different this time from all the others and some things i can come up with are:
  • This was a Roku 4

  • Dev.mode was never enabled on this particular player before

  • This user account has never enabled dev.mode before (player is linked with another user account, not my personal)
0 Kudos
3 Replies
belltown
Level 7

Re: Enabling developer mode hangs Roku4 @7.0?

I wonder if it's related to this dev-mode issue: http://forums.roku.com/viewtopic.php?p=512910
https://github.com/belltown/
0 Kudos
EnTerr
Level 8

Re: Enabling developer mode hangs Roku4 @7.0?

"belltown" wrote:
I wonder if it's related to this dev-mode issue: http://forums.roku.com/viewtopic.php?p=512910

No idea. I just tried what you reported there to cause hanging in 7.0.9037 @3100 and changing password does not hang in 7.0.9044 @4200. So maybe it's a multi-model uhhh, ahh... "behavior" that gets fixed between builds 9037 and 9044 of fw7?

The Roku 4 above was at 8863. Hm, do we even know if build numbers are cross-model comparable?!
0 Kudos
belltown
Level 7

Re: Enabling developer mode hangs Roku4 @7.0?

Mine still hangs when trying to change the developer password on 7.0/9044 on my 3100X (Roku 2XS). Looks like different problems on different firmwares/models. I tried your sequence on my device and that worked okay.
https://github.com/belltown/
0 Kudos