Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
grock
Level 7

Eclipse plugin page 404

Has this been moved?

https://devtools.web.roku.com/ide/eclipse/plugin

404 Not Found

Code: NoSuchKey
Message: The specified key does not exist.
Key: ide/eclipse/plugin
RequestId: 661CBDC0DF4C224E
HostId: lRklbqydoredt/xSfauwrEhb/1hK4PsUOIUqk/Dqp0kh0DlO4cP+uNutnahqjyGJGSoaOemXZ9I=
0 Kudos
6 Replies
EnTerr
Level 8

Re: Eclipse plugin page 404

No - believe it or not - i am told that is the correct URL and it works!
See https://github.com/rokudev/docs/issues/12 
0 Kudos
Wanda
Level 7

Re: Eclipse plugin page 404

Actually, I'm using that page and I keep getting an error message saying the core isn't there, but I see the core there. Any ideas as to what's going on?
0 Kudos
EnTerr
Level 8

Re: Eclipse plugin page 404

"Wanda" wrote:
Actually, I'm using that page and I keep getting an error message saying the core isn't there, but I see the core there. Any ideas as to what's going on?

You talking about this?
"https://forums.roku.com/viewtopic.php?f=34&t=99541#p552367" wrote:

"Missing requirement: BrightScript Core 1.2.0.201610272359 (com.roku.brightscript.ide.eclipse.core.feature.group 1.2.0.201610272359) requires 'org.eclipse.dltk.core 5.0.0' but it could not be found"

The complaint is not that B/S core is missing but that DLTK, whatever that is. Have you satisfied the requirements for the plugin - e.g. that you need a very specific version of Eclipse?
The instructions say "The new plugin required Eclipse 4.5 (Mars) as a minimum, DLTK 5, and Java 8. "
Which version of Eclipse are you trying this with?
0 Kudos
Wanda
Level 7

Re: Eclipse plugin page 404

EnTerr, I am using: Eclipse IDE for Java Developers, Version: Neon.2 Release 4.6.2

What do I need to install? I mean, can I do an upgrade or do I have to uninstall Eclipse?
0 Kudos
EnTerr
Level 8

Re: Eclipse plugin page 404

"Wanda" wrote:
EnTerr, I am using: Eclipse IDE for Java Developers, Version: Neon.2 Release 4.6.2

What do I need to install? I mean, can I do an upgrade or do I have to uninstall Eclipse?

No clue, i am afraid.
Neon is one version after Mars, maybe it comes with incompatible version of DLTK.
Two ideas - try to install DLTK 5 in said Neon (maybe it comes with incompatible version) or just scrap the Neon and download Mars.
0 Kudos
Wanda
Level 7

Re: Eclipse plugin page 404

Thank you very much. I went to the Eclipse site and I"m installing Eclipse 4.5 (Mars). Hope it works. I really appreciate you trying to help me. 
0 Kudos