Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Re: Eclipse plugin for Brightscript

Ah, hmmm, I finally got it to work on my Mac. I think I had to use the 64bit version of Eclipse with the 64bit version of Java 1.6, and then reboot before installing the Brightscript plugin.

When I did those things, I now get Brightscript bits.

We'll see how things go further.
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

"migmigmig" wrote:
Ah, hmmm, I finally got it to work on my Mac. I think I had to use the 64bit version of Eclipse with the 64bit version of Java 1.6, and then reboot before installing the Brightscript plugin.

When I did those things, I now get Brightscript bits.

We'll see how things go further.


OK, let me know how things go.
But... I have to say I'm surprised you are seeing anything other than a stacktrace/error message at this point.
The last published beta version of the plugin has an expiration of 4/1/2011, so it should have failed with an expiration exception during the plugin load.
I'll have to look into that - it's likely the overall environment is taking clues from the plugin manifest, but that the actual plugin code is lazy-loaded.

Cheers
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

An FYI to all those interested in Eclipse IDE support -

I am pleased to announce that Roku has hired me on a contracting basis to merge my plugin with a plugin they were working on independently - to get the best of both in a single Roku-supported Eclipse plugin.
This will move the development of the plugin along a bit faster than it has been to date.
We're working on getting something released as soon as possible with the merged feature set - so stay tuned.

After the initial release, we will of course be adding to and improving the feature-set based on feedback from all you Roku channel developers.
Any suggestions for additional features or modifications to the existing features would be very much appreciated.

Cheers
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

Groovy, good to know this may go to the level of an actual approved devtool. And I was surprised as you to see it work fully and completely, but I'm not going to complain.

I will, however, feel free to gently complain about whatever bugs I do find. Smiley Happy

1) One of the things I did notice is that doing an array dereference from the results of a function call cause a spurious syntax error to be detected in Eclipse.

If you load the sdk "videoplayer" sample into the ide, you can see the spurious errors reported.

2) Another thing I noticed was that the Export dialog wasn't remembering the checkbox settings for the folders -- when I tried to include the "xml" folder from the videoplayer sample, I had to keep checking the box on every export.

3) It would be great if the run/debug keys (cmd-f11, etc) could do an auto-export with the user's last saved values from the export dialog.

mig
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

Does "The BrightScript plugin's beta period has expired" today/yesterday? For me it started showing this error.

You say that expiration was set to 01-04-2011. But it looks like the real expiration date is 01-05-2011.

Is the new version expected?
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

I agree. Coming in to work today, I was completely cut out of my project code after loading eclipse. Smiley Sad

Any new version? Can we just have an update of the old one without the expiration date?
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

"dmitskevich" wrote:
Does "The BrightScript plugin's beta period has expired" today/yesterday? For me it started showing this error.

You say that expiration was set to 01-04-2011. But it looks like the real expiration date is 01-05-2011.

Is the new version expected?


Yes, it does appear the code sets the expiration date to 5/1/2011, not 4/1/2011 as I had thought ( a date/time method arg I thought was 1-based is in fact 0-based, hence the off-by-1 error).
The new version is nearly code-complete and should soon be in QA, pending an internal feature/implementation review.
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

ETA?

I can go back to text edit but it feels like going from the iron age back to the stone age.

Please take our desperation as an indication of our affection for your wonderful plugin. Smiley Happy
0 Kudos
Highlighted
Level 7

Re: Eclipse plugin for Brightscript

Actually, after trying to live today without it, I'll ask again:

Can we have the previous version with maybe a June expiration date? To hold us over till you're out of QA?

Uberplease?
0 Kudos
Highlighted
Level 8

Re: Eclipse plugin for Brightscript

Hi All,

I'm suddenly getting the following error in Eclipse (was working on Friday 4/29) when trying to create a new BrightScript project:

The selected wizard could not be started.
Plug-in com.domhain.brightscript.plugin was unable to load class com.domhain.brightscript.plugin.wizards.newproject.BrightScriptProjectWizard.
An error occurred while automatically activating bundle com.domhain.brightscript.plugin (228).


I saw someone else had this issue and resolved it by uninstalling and installing, but that did not work for me. Is there any kind of resolution to this??

Tech Details:
OS: Windows 7 (also broke on Mac 10.6.7)
Eclipse Version: 1.0.0.201101111145
Java Version: 1.6.0__25


Thanks
Bud
0 Kudos