Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
renojim
Level 8

Bug in v7.0 (Roku SE only?)

I don't know if this bug existed before v7.0 and/or if it's only the SE (I'm told it's identical to the Roku 1), but GIFs are not handled properly in at least two places (and before anyone says it, yes I know I'm probably the only person still using GIFs):
  • Using a GIF for the splash screen (splash_screen_xx in the manifest)

  • Using a GIF for the mm_icon_focus_xx and then sideloading (icon on Home screen is wrong)

In both cases it appears that the GIF may be XORed with some background color.

The SE is the first "Roku 1" type device I've owned, so I've only seen v7.0 build 9021. I have a few published channels that use GIFs in their splash screens, so I'm just finding out now that they aren't being displayed properly. Smiley Sad

-JT
0 Kudos
2 Replies
EnTerr
Level 8

Re: Bug in v7.0 (Roku SE only?)

ha! did not know GIFs can be used there. Won't put-down GIF, it can be quite compact and useful.

If you saw the mis-behavior on Roku SE, my gut feeling is same will be the case on the rest of 27xx and 5xxx players. TBD re 3xxx and 4xxx - you did not mention explicitly if issus is there fw7? (give channel ID if you need us to test)
0 Kudos
renojim
Level 8

Re: Bug in v7.0 (Roku SE only?)

My private Speed Test and Wake-on-LAN channels use GIFs. For a public channel, there's SomaFM. None of them show a problem on my Roku 3 running fw v7.0 or my new RokuTV running fw v6.x.

-JT
0 Kudos