Roku Developer Program

Join our online forum to talk to Roku developers and fellow channel creators. Ask questions, share tips with the community, and find helpful resources.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
destruk
Level 10

Bug/Leak buffering files

If I play a video with roVideoScreen, and it starts to buffer the video, and I press UP to cancel, and then tell it to play again 6 or 7 times in a row, the roku crashes and has to be rebooted - all telnet says is "connection to host lost" - is there a fix for this?
0 Kudos
3 REPLIES 3
bandal
Level 8

Re: Bug/Leak buffering files

I have seen this before a few times, The sandbox cannot handle this.
0 Kudos
RokuMarkn
Level 9

Re: Bug/Leak buffering files

This shouldn't happen. Destruk, can you PM me the serial number of a box on which you reproduced this, and the approximate date(s)/time/timezone of when it happened?

--Mark
0 Kudos
destruk
Level 10

Re: Bug/Leak buffering files

PM sent - just happened again (forum timestamp should help)
If there is no way to 'correct' it through the script, then that's fine and I'll stop trying to fix it.
What happens most of the time, when it doesn't say connection to host lost, is it returns to the springboard screen but the remote control is unresponsive - the only button that seems to work is the home button.
When breaking into the debugger it shows that it thinks it is in the wait loop for the springboard screen and the msg returned is the previous play video value.
0 Kudos