Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Samsung S20 No Longer Mirroring

I've used the Smart View feature on my Samsung Galaxy S20 Android phone to mirror/cast my phone  screen to my Roku 4K Streaming Stick many times. Now, my Smart View detects and displays the Roku Streaming Stick, but when I click on Start Mirroring. it never connects. I tried removing my phone from the devices allowed and turned the TV off and on, but no luck. 

I can mirror to the LG TV fine by choosing it (LG Web OS UN7000) rather than the Roku so I know it's not a WiFi problem. Both the LG Web OS and Roku did updates recently so I assume one of those updates is to blame. I much prefer the Roku remote to the fussy LG remote so hope someone can suggest an easy fix. 

0 Kudos
Binge Watcher

Can't mirror Samsung S20 screen on Roku Premiere 3920RW using Smart View

Dear All, I have a Roku Premiere (3920RW software version 11.5.0 revision 4312-91) and a Samsung Galaxy S20 SM-G980F with OneUi 5.1 and Android 13.

I can mirror my S20 screen directly on my Samsung TV (it supports both Samsung Smart View and AirPlay). 

I can also mirror it using my Chromecast.

I can also mirror both my iPad and MacBookPro screens on my Roku Premiere using AirPlay.

But I can't mirror my S20 on Roku. When I start Smart View on S20, it shows my Roku device as available mirror device. But if choose it, no message appears on Roku asking to accept the connection and after some time Smart View on the S20 gives up and shows a message about pressing the power button on the the TV (obviously the message doesn't apply to me since I am trying to mirror to a Roku device, not a TV).

I tries with another Samsung phone (a friend's S21) but it also does not work.

I already tried the available suggestions I found, as setting the configuration do "Prompt", restarting all devices, restarting the access point and changing Wi-Fi from 2.4Ghz to 5Ghz (my Roku device actually doesn't support 5GHz wi-fi network).

I wonder if anyone here knows what to do in order to fix this.

Thanks a lot.

0 Kudos