Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
chicca
Reel Rookie

youtube and youtube tv not loading on Roku

Today I purchased Roku Express 4K+ and I connected Roku to my TV.

I added several channels, including YouTube and YouTube TV, but when I click to load them, they don't appear.

I had no problem watching YouTube with my first Roku.

Have I purchased a faulty Roku that I should exchange for another one?

Any suggestions would be very welcome.

0 Kudos
12 REPLIES 12
jerryoprisko
Channel Surfer

Re: youtube and youtube tv not loading on Roku

I'm having problems also with signing into youtube tv.  After DL the APP, ROKU prompts me to sign in to tv.youtube.com/start, to insert the code on their screen, and this site will not open either on my PC or Cell phone

0 Kudos
renojim
Community Streaming Expert

Re: youtube and youtube tv not loading on Roku

@jerryoprisko, that's not a Roku problem; it's a Google problem.

How about:
https://accounts.google.com/o/oauth2/device/usercode?pageId=none&flowName=DeviceOAuth

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
chicca
Reel Rookie

Re: youtube and youtube tv not loading on Roku

Thank you for your answer.

I was able to fix the problem by unplugging and re-plugging Roku.

Happy 2023!

0 Kudos
jerryoprisko
Channel Surfer

Re: youtube and youtube tv not loading on Roku

Ya, thanks, that was my first thought, do a hard re-start, turned everything off including router and still Roku would not allow sign in, kept telling me "improper code" whenever I could try a sign in. They even gave me an option of using my Cell phone with YouTube app open, Roku would not recognise it.

However, I found  Amazon's elegant solution, I downloaded the YouTube app and YouTubeTV app and at the bottom of the left hand corner of the opened app it asks the question, "Do you want to open /go toYouTubeTV? Clicking on it goes right to content., sweet!

jerryoprisko
Channel Surfer

Re: youtube and youtube tv not loading on Roku

Tried that about a dozen times and Roku informs me "Improper code".  But i foung Google's fix, Dl both YT and YTTV app jump from one to the other easily with no Roku hassle.

chicca
Reel Rookie

Re: youtube and youtube tv not loading on Roku

Wow, I'm impressed!

If I hadn't been able to easily fix the YouTube problem, I'd have returned to the store to exchange the "faulty" Roku for another Roku. 

😉

0 Kudos
bobsled101
Reel Rookie

Re: YouTube TV not funtioning on all 3 of my devices

After installing YTTV app  and signing in on any of my 3 devices it will work only 1 time. If I close the app and open later it will not load properly. All are up to date, I have rebooted multiple times with no luck. I have been in touch with YTTV with no solution found. I have been watching YTTV on these same devices for years with no problem until about 2 weeks ago. I have much info ( issue ID numbers, software versions, device ID's and much more) to share if I could only get in touch with someone from Roku. VERY frustrating, may have to purchase different devices which I do not want to do. Can ANYONE help me.

0 Kudos
jerryoprisko
Channel Surfer

Re: YouTube TV not funtioning on all 3 of my devices

Try DL YouTube APP,  when it opens, go to the left side and at the bottom it offers  "Go to YouTube TV"?

Click on it and it should go to YouTubeTV and allow entry. There are YT videos demonstrating this.  Good luck

0 Kudos
bobsled101
Reel Rookie

Re: YouTube TV not funtioning on all 3 of my devices

It makes no difference, works the same on either app. The longer I have this problem the more I learn about it. Starting from scratch(no app installed), I install the YTTV app and log in. It works perfectly until I switch to another app. The next time I open YTTV it will do one of two things. 1- it opens and asks me to log on again (it would always open without requiring log on before), then works ok, or 2: More often than not it will open to the home screen as usual (getting my hopes up) but only for a couple of seconds then the "theme song" will play and a screen with the logo will appear for a second or two, then a black screen. If I try with my smart tv the app always works just great. The same problem on all 3 of my Roku devices.