Channels & viewing

Are your Roku channels not working? Find troubleshooting tips for adding/removing channels, logging in, authentication, activation, playback issues, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Britbox on Roku Channel app

Installed the "Britbox on Roku Channel" app last month.  Everything was working fine until today and I'm now getting ads.  Why am I paying 7.99 a month for ads?  I tried using chat to speak with support, but they haven't been helpful.  In the last message they told me to contact Britbox.  I don't have a Britfox subscription.  I am at a loss and the technical support is not helpful and slow to respond.

Unless I'm missing something, a word of warning.  If you want Britbox subscription, go through Britbox and not Roku.  

Very confused 

0 Kudos
Retired Moderator

Re: Britbox on Roku Channel app


Thanks for the post.

We would be more than happy to look further into the issue, but need more details about what you are experiencing? What specific content are you watching that you are seeing ads on? What content were you watching previously and did not have ads?

With more detailed information, we will be able to assist you further.


Danny R.
Roku Community Moderator
0 Kudos

Re: Britbox on Roku Channel app

I have been watching Britbox the sane way for years. Starting mid September it started having loading issues. I was reinstalling the apo and having success with that but now that no longer works. 

There is nothing wrong with my account as I can watch on other platforms. 

I contacted Britbox and they sent a statement saying the have fixed the issue and we need to wait on Roku to roll out the update. Meanwhile I'm paying for the service. Wondering when this will be updated. 




0 Kudos
Retired Moderator

Re: Britbox on Roku Channel app

Hello @JenelleB

Thanks for reaching out here in the Community.

Did you restart your Roku device before re-installing the channel? That step is crucial when performing the troubleshooting. If you haven't tried the suggested order (remove > restart > re-install), we would recommend giving it a shot once again. We also suggest doing the restart from the Settings menu by navigating to Settings > System > Power (If you do not see a Power submenu, skip to the next step.) > System restart.

For detailed instructions, refer to this Support link: How do I resolve channel playback issues?

Let us know how it goes!



0 Kudos