Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 9

Re: Roku tv not showing the thumbnail pictures

Jump to solution

I think it's a bug too. Last night when I switched from antenna I got the background screen on the home screen and no icons at all. I went back to antenna and it was just a blank screen. I finally had to unplug it and everything came back afterwards. This is really annoying and TCL is no help at all. I'll never by another tv of there's again!

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Level 13

Re: Roku tv not showing the thumbnail pictures

Jump to solution

I will occasionally see the same issue with Prime Video on my 32" S-Series TCL Roku TV. Others have mentioned deleting apps to save some memory resources, but I have 60+ apps on my S-Series and it only happens rarely and only with the Prime Video app. When it does occur I find that doing a RESTART will correct the issue. SETTINGS -- SYSTEM -- POWER -- SYSTEM RESTART -- RESTART. The same as pulling the plug, but you just need your remote to get it accomplished. Probably not a bad idea to just perform a RESTART/REBOOT of this older device weekly to clear out any cobwebs that build up. I still think this is a Prime VIdeo / Roku OS bug more than deleting a large portion of the apps you have installed.

TCL Roku-TV 55P605 (4K/HDR/DV) | VIZIO SB36512‑F6 ATMOS Soundbar | Fire TV Stick 4K
TCL Roku-TV 43S425 (4K HDR) | Fire TV Stick 4K
TCL Roku-TV 32S301 (720p) | Fire TV Stick 4K

View solution in original post

3 Replies
Highlighted
Level 13

Re: Roku tv not showing the thumbnail pictures

Jump to solution

I will occasionally see the same issue with Prime Video on my 32" S-Series TCL Roku TV. Others have mentioned deleting apps to save some memory resources, but I have 60+ apps on my S-Series and it only happens rarely and only with the Prime Video app. When it does occur I find that doing a RESTART will correct the issue. SETTINGS -- SYSTEM -- POWER -- SYSTEM RESTART -- RESTART. The same as pulling the plug, but you just need your remote to get it accomplished. Probably not a bad idea to just perform a RESTART/REBOOT of this older device weekly to clear out any cobwebs that build up. I still think this is a Prime VIdeo / Roku OS bug more than deleting a large portion of the apps you have installed.

TCL Roku-TV 55P605 (4K/HDR/DV) | VIZIO SB36512‑F6 ATMOS Soundbar | Fire TV Stick 4K
TCL Roku-TV 43S425 (4K HDR) | Fire TV Stick 4K
TCL Roku-TV 32S301 (720p) | Fire TV Stick 4K

View solution in original post

Highlighted
Level 7

Re: Roku tv not showing the thumbnail pictures

Jump to solution

blade_005's solution fixed the issue I was having for my Roku 55C807. I was able to hear the audio for inputs in HDMI 1, 2, or 3, but the video was not displaying. Restarting through the Power menu fixed this problem. Thanks!

0 Kudos
Highlighted
Level 7

Re: Roku tv not showing the thumbnail pictures

Jump to solution

I was having this same issue. Not sure if using Amazon Prime is what caused the app icons to disappear, but using the reset option fixed the issue.

0 Kudos