Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
akhenbagi
Newbie

Roku speakers WiFi question

I can’t find specific information about how the Roku speakers connect to my Roku TV I understand it’s a direct connect wireless. I’m assuming 2.4ghz? Anyone know what channel? About every 5 days or so my speakers won’t connect to the TV unless the TV is restarted. I’m trying to narrow down more to see if it’s a WiFi issue. I’ve tried TV on 5ghz and on 2.4ghz networks same problem. I have no other WiFi near me except my own. 3 APs cover the house. (Channel 1,6,11) and 5ghz is spread so there’s no overlap as well. (UniFi gear). Thoughts? I’d love to get the Sub and maybe Soundbar, but not if I continue to have this issue.

Labels (1)
0 Kudos
2 REPLIES 2
renojim
Community Streaming Expert

Re: Roku speakers WiFi question

I'm fairly certain they use Wi-Fi direct like the voice remotes, so they're using whatever band and channel the TV is using to connect to your Wi-Fi.  It's more of an educated guess than anything, so if anyone has more information I'd like to hear it.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
AvsGunnar
Community Streaming Expert

Re: Roku speakers WiFi question

Although this is likely a spam user (this same question, word for word, sentence for sentence, posted on a couple different forums by a different user from 2 years ago), still a valid question. 

There are indications that when using APs with varying/different channels from the RokuTV that the speakers are paired with, that provide overlapping connection coverage, the speakers can become confused as to the actual channel it should connect on and occasionally disconnect whenever the RokuTV wireless channel changes or loses network connection.

The above should be less impactful if the Auto wireless channel selection settings of the router and the APs are disabled.  Manually assign a channel to each (at router and APs) or configure to use same channel across network on the appropriate band. (not all APs allow this configuration so need to try to get as close as possible or work within the limits of your AP's settings and maybe move AP to avoid conflicts.).  Another solution may be use different SSID names at APs to help mitigate confusion.

Basically, need to disable auto channel selection and try either (1). staggering wireless channels, (2.)using same wireless channels, (3)use different SSIDs.

 

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos