Roku Direct Publisher

The easiest way to create a great TV experience.
cancel
Showing results for 
Search instead for 
Did you mean: 
jonlamas
Level 7

Some Episodic Thumbnail Images Not Loading

Our Roku Channel utilizes a Direct Publisher feed. Recently we noticed that some of the episodic thumbnail images, when viewing on Roku 4, are not showing up. We only see a "?" where the image should be. This isn't the case for all thumbnail photos, but it impacts a majority of them. For instance, one show has 4 broken thumbnails and two that are appearing correctly. Another show has all broken thumbnails. That said, all of the episodic thumbnail images appear fine on a Roku 3 and Roku Express.

We first checked to make sure all the images are truly working in our feed. They are. We then did a hard reset of our Roku 4 device, then re-subscribed to our Channel. Unfortunately this did not fix the issue. Has anyone else experienced this problem, and if so, do you know of a fix?
0 Kudos
3 Replies
Roku Employee
Roku Employee

Re: Some Episodic Thumbnail Images Not Loading

Can you share your channel install code? And perhaps even the content feed? Feel free to message it to me directly if you don't want to share publicly. I'll help troubleshoot.
0 Kudos
jonlamas
Level 7

Re: Some Episodic Thumbnail Images Not Loading

Thanks Tom. I'm going to send you our details in a PM.
0 Kudos
Bwright
Level 7

Re: Some Episodic Thumbnail Images Not Loading

I am having the same issue I believe. The thumbnails in certain channels are only showing question marks. I have 2 different devices and it appears to only be happening on the one. I have restarted the device and checked for updates. I am not sure what else to try.
0 Kudos