Roku Direct Publisher

The easiest way to create a great TV experience.
cancel
Showing results for 
Search instead for 
Did you mean: 
Bigmike333
Level 7

My Live Streaming Channels Quit on Me

Hello, I have a few live video channels up in the Channel Store. When I go to watch them now, they never loads, and therefore fail to play. I can play the video streams on VLC player, so I know it is being delivered from the CDN. Did something change perhaps, that I am not aware of? These are all published channels, showing up in the Channel Store. One such channel is PBN Radio. My json files didn't change, so just wondering if anyone has info on this. I am using Direct Publisher by the way. Thanks!
0 Kudos
13 Replies
tim1607
Level 7

Re: My Live Streaming Channels Quit on Me

Hey BigMike333,

Can you get to the JSON files?  If you got the json url do you see the file?  That would be the first thing that I would check, just thinking here.  

Tim
0 Kudos
Bigmike333
Level 7

Re: My Live Streaming Channels Quit on Me

Yes, I have the json files. I copy the url from them and paste into VLC, and the files stream fine. Roku ingests the feeds, but will not push them through the players for some reason. I also have a private channel I am using for development. When I put these urls into that json file, same thing happens. It will not play the videos on the private channel either. This was all working fine, recently.
0 Kudos
mosafer
Level 9

Re: My Live Streaming Channels Quit on Me

Try Roku Stream Tester and look if your stream is working there:
http://devtools.web.roku.com/stream_tes ... index.html
0 Kudos
tim1607
Level 7

Re: My Live Streaming Channels Quit on Me

Hi again Mike,

Sorry that you are going through this.  What I meant about the feed url is this, if you put the feed url into a browser window, do you see the json?  Using either Firefox or Chrome you should be able to see the "pretty" version of the feed JSON.
I understand that you have the JSON's and the videos pull up in VLC but if Roku devices can't see the JSON then the videos won't come through the only thing that you will see on your channel is the information that was set up with the channel on the ROKU side of it.  Maybe I am misunderstanding what you are and are not seeing. 
My concern is that the server hosting the feed url is down, or no longer allowing that traffic.
0 Kudos
Bigmike333
Level 7

Re: My Live Streaming Channels Quit on Me

The feeds did not play in the Roku Feed Tester. Got about the same result, progress bar goes up to about 10% then stops. This same results from three different encoders / streams. Tried HLS, MP$, and DASH streams.
0 Kudos
Bigmike333
Level 7

Re: My Live Streaming Channels Quit on Me

The Direct Publisher interface verifies the json url, and status of the content as being fine. The url put into VLC was the one I copied out of my json file, using chrome browser and an online json editor program.
0 Kudos
Bigmike333
Level 7

Re: My Live Streaming Channels Quit on Me

My CDN verified the streams are being sent, and there were no changes on their end. 
0 Kudos
tim1607
Level 7

Re: My Live Streaming Channels Quit on Me

Hi Mike, 

Having worked in support for the last 20 years for hosting and SASS companies, I can tell you, it's never my fault.  But that doesn't resolve the issue.  

A. Can you pull up the full JSON in a browser?
B. Is your CDN or even the hosting of the JSON seeing any errors?  Errors would be in the HTTP logs for the web server or the content server. 
0 Kudos
37mediagroup
Level 9

Re: My Live Streaming Channels Quit on Me

I tried adding the channel. First, are you sure this is the Direct Publisher version?  Looks like a custom site, although admittedly I've never seen a 1 stream DP channels layout). Secondly yeah it seems to get stuck in the loading stream phase.

Following what Tim said, I would check the JSON feed (pull it up in Chrome to see the 'pretty' version with layout indentation, colors etc), the video URLs to make sure they work, and lastly check your json feed. Possibly when you were building the new site you copied & pasted a URL incorrectly, or mistakenly deleted a letter in a URL. Maybe just upload a 2nd version of the json & paste its URL into the DP feed.
0 Kudos