Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ZandzOfTime
Level 7

mp4 and <media:content url...

Hello,

I am trying to play video from xml file, server generates a big list media:content url for what appears to be each video. When in videoplayer I send all url's as array it does not play, but if I select url[0] or other it plays. What is the method for passing the urls and bitrate list correctly to the video player. The documentation indicates that one passes an array of video urls and bitrates, but so far it only works when I pass a single video and bitrate for playback.

Also in the qualities field, it looks like one should pass ["SD","HD"] but it only works if I pass a single value ["SD"].

- Zandz
0 Kudos
4 Replies
dynamitemedia
Level 8

Re: mp4 and <media:content url...

show us an example of what the xml is showing, did you make the changes to your showfeed.brs (if you used the video player example)

also i just posted a working sample you could follow viewtopic.php?f=34&t=37831
Twitter: iptvmyway facebook: iptvmyay
Channels: Warriors of War, Go Fight Live, Heading Outdoorz, IPTVmyway
0 Kudos
ZandzOfTime
Level 7

Re: mp4 and <media:content url...

Ok, i now have it working, I was testing on SD screen and it seemed nothing would play, then out of curiousness I tried on HD, and all videos worked! Then I found some vids actually did work on SD, so I reason that I must detect the resolution and force all qualities to SD if roku is in SD mode, now works on both HD and SD!

Thanks for the help, this is very not well documented in manuals.

I also wonder if faster way is possible to get all values from the xml, instead of parse each media:content tag for each video (loop in loop) into associative array for poster then again parse each value into a sparate array for each value of bitrate streamformat quality url ( this is one loop with many arrays! too many arrays!) it is lots and lots of looping and slows down things!

- Zandz
0 Kudos
TheEndless
Level 9

Re: mp4 and <media:content url...

"ZandzOfTime" wrote:
Thanks for the help, this is very not well documented in manuals.

Per the roVideoScreen section (4.5) of the component reference:
"ComponentReference" wrote:
If the StreamQuality is set to HD, and the user display type is set to SD, the HD stream will not be selected.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
0 Kudos
ZandzOfTime
Level 7

Re: mp4 and <media:content url...

Ah, my bad!

Thank you!

Z.
0 Kudos