Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
chaklasiyanikun
Level 11

With HTTPS URL image not load with Poster Grid

I created one RSG Component and stored content using content-meta-data like below.  Inside a content-meta-data field is hdgridposterurl here, I put Both URL HTTP and HTTPS and Checked Roku side, It's working or not. Http is Working. But, Https is not Working. I also checked both URLs on a different platform. Both URLs Working well for other platforms like Android, IOS, Google Chrome, Amazon Fire Stick.

I also add SetCertificatesFile("common:/root/www_mysite_com.csr"). It's not working. This is the same problem with all RSG components and simple Poster node. Does anyone know any solution for this? 

 

PosterGrid Example :

<component name = "PosterGridExample" extends = "Scene" initialFocus = "examplePosterGrid" > 
  <script type = "text/brightscript" >
    <![CDATA[
    sub init()
      m.top.backgroundURI = "pkg:/images/rsgde_bg_hd.jpg"
      m.top.setFocus(true)
      m.postergrid = m.top.findNode("examplePosterGrid")
      m.postergrid.translation = [ 130, 160 ]
      m.readPosterGridTask = createObject("roSGNode", "ContentReader")
      m.readPosterGridTask.contenturi = "http://www.sdktestinglab.com/Tutorial/content/rendergridps.xml"
      m.readPosterGridTask.observeField("content", "showpostergrid")
      m.readPosterGridTask.control = "RUN"
    end sub
    sub showpostergrid()
      m.postergrid.content = m.readPosterGridTask.content
    end sub
    ]]>
  </script>
  <children>
    <PosterGrid
      id = "examplePosterGrid"
      basePosterSize = "[ 512, 288 ]"
      caption1NumLines = "1"
      numColumns = "2"
      numRows = "2"
      itemSpacing = "[ 20, 20 ]" />
  </children> 
</component>

 

Content-Meta-Data : 

<Content >
  <item hdgridposterurl = "http://www.sdktestinglab.com/Tutorial/images/rectanglepg.jpg"
    shortdescriptionline1 = "Rectangle Node"
    x = "0" y = "0" />
  ...
</Content>

 

0 Kudos
8 REPLIES 8\
sanity-check
Level 9

Re: With HTTPS URL image not load with Poster Grid

I haven't had any issues with https images... In the particular example you posted there's an issue with the cert being expired on www.sdktestinglab.com (my browser warns me about it), which seems likely to be the cause. Can you load images from other sites over https?
0 Kudos
chaklasiyanikun
Level 11

Re: With HTTPS URL image not load with Poster Grid


@sanity-check wrote:
I haven't had any issues with https images... In the particular example you posted there's an issue with the cert being expired on www.sdktestinglab.com (my browser warns me about it), which seems likely to be the cause. Can you load images from other sites over https?

I'm sorry, I forgot to change the URL in Content-Meta-Data. So, I Put Roku Example URL as It is. It's working with HTTP. http://www.sdktestinglab.com/Tutorial/images/rectanglepg.jpg 

0 Kudos
chaklasiyanikun
Level 11

Re: With HTTPS URL image not load with Poster Grid

I added a certificate like below and display loadStatus and FailedBitmapUri. here, loadStatus = "failed" display. But, the FailedBitmapUri image is not displaying. In Google Chrome successfully Loading But, Roku not loaded. I think Roku does not decode the image. But, I don't know why? I'm Still not Found any solution for this.

sub init()
m.poster = m.top.findNode("testPoster")
m.poster.SetCertificatesFile("pkg:/certificates/cacert.crt")
m.poster.InitClientCertificates()http://www.sdktestinglab.com/Tutorial/images/rectanglepg.jpg
m.poster.uri="https://myURL:1400/Image.jpg"
m.poster.failedBitmapUri="pkg:/images/splash_hd.jpg"http://www.sdktestinglab.com/Tutorial/images/rectanglepg.jpg
m.poster.observeField("loadStatus","OnLoadStatusChanged")
m.top.SetFocus(true)
End sub
function OnLoadStatusChanged()
?"m.poster.loadStatus : "m.poster.loadStatus
end function

 

0 Kudos
chaklasiyanikun
Level 11

Re: With HTTPS URL image not load with Poster Grid

Image URL is: https://myURL:1400/Image.jpg 

I think the problem with a colon and port. Because it's the same thing that happened in the video URL also. I found the Same problem with the Video URL also.
Video URL is: https://myURL:4500/video.mp4  
Does anyone know how to resolve this issue?

0 Kudos
chaklasiyanikun
Level 11

Re: With HTTPS URL image not load with Poster Grid

Both URLs here have ports and do not run with ports URLs. I checked Without Port URLs(https://myurl/Image.jpg) in Roku. It's Working fine. Is there any solution for how it's enabled with port URLs?

I'm not sure. Does it matter, if the server is running without port or running with a port?

0 Kudos
renojim
Community Streaming Expert

Re: With HTTPS URL image not load with Poster Grid

Your URL for the image has a double slash after the port.  There should only be one - i.e.,  https://simultv.com:1400/nodeapi/Channels/file-1591699694712.jpg 

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
renojim
Community Streaming Expert

Re: With HTTPS URL image not load with Poster Grid

That's weird.  I replied to this earlier and now it's gone.  Anyway, your URI for the image has a double slash after the port number.  It should be only one and is probably tripping up the transfer.  I don't know about the video problem.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
chaklasiyanikun
Level 11

Re: With HTTPS URL image not load with Poster Grid


@renojim wrote:

That's weird.  I replied to this earlier and now it's gone.  Anyway, your URI for the image has a double slash after the port number.  It should be only one and is probably tripping up the transfer.  I don't know about the video problem.


Thank you For your great response. I have already checked with a single slash and double slash. Both ways, I getting load status failed in Poster Node.

0 Kudos