Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Unable to install eclipse plugin

Hi,
I'm try to install eclipse plugin but failed to install as following reason .I'm using eclipse kepler with JRE 1.7 on Ubuntu 12.04

The operation cannot be completed. See the details.

Details:

Cannot complete the install because one or more required items could not be found.
Software being installed: BrightScript Core 1.0.0.201310291810 (com.roku.brightscript.ide.eclipse.core.feature.group 1.0.0.201310291810)
Missing requirement: BrightScript Plugin 1.0.0.201310291810 (com.roku.brightscript.plugin 1.0.0.201310291810) requires 'bundle org.eclipse.dltk.debug.ui [2.0.0,2.1.0]' but it could not be found
Cannot satisfy dependency:
From: BrightScript Core 1.0.0.201310291810 (com.roku.brightscript.ide.eclipse.core.feature.group 1.0.0.201310291810)
To: com.roku.brightscript.plugin [1.0.0.201310291810]
0 Kudos
1 Reply
Highlighted
Level 7

Re: Unable to install eclipse plugin

"arifkhan" wrote:

Cannot complete the install because one or more required items could not be found
...
Missing requirement: BrightScript Plugin 1.0.0.201310291810 (com.roku.brightscript.plugin 1.0.0.201310291810) requires 'bundle org.eclipse.dltk.debug.ui [2.0.0,2.1.0]' but it could not be found


That pretty much points to the problem. You are missing at least one dependency - the DLTK 2.0 core plugin.

Did you add and make active the required additional eclipse update sites (for DLTK and EMF) as stated in the installation section of the plugin guide ( http://sdkdocs.roku.com/display/sdkdoc/Eclipse+Plugin+Guide ) prior to attempting to install the BrightScript plugin?

Cheers
0 Kudos