Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
sonnykr
Level 7

[Solved] Eclipse Brightscript Plugin Error

Hi All,

I was trying to install brightscript plugin on my mac. But once i create a project, and try to Run (Export), its showing me error:



http://snag.gy/Vx4pf.jpg

Error in setting developer mode credentials
Either the username or the password is not valid
Reason: The developer password must not be null when creating an authentication class instance.

I downloaded eclipse from https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/lunar

I also tried Eclipse IDE for Java developers https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunar
0 Kudos
14 Replies
whynotmatt
Level 7

Re: Eclipse Brightscript Plugin Error

I am seeing the same error. I don't see any place in the project settings to enter a dev password.
0 Kudos
NewManLiving
Level 7

Re: Eclipse Brightscript Plugin Error

I think it's the password and id of your development box
I recall that I had to reset it for one of my
Eclipse installations. In the export wizard you
Should see the username
My Channels: 2D API Framework Presentation: https://owner.roku.com/add/2M9LCVC
Updated: 11-11-2015 - Completed Keyboard interface
The Joel Channel ( Final Beta )
0 Kudos
sonnykr
Level 7

Re: Eclipse Brightscript Plugin Error

On windows I dont remember getting any error like this. But now, I am not able to proceed to the export page bcz of this error. I know we can give dev id and password in Brightscript deployment wizard, and in this case due to this error I cant get there.

Is there somewhere else (like an xml file) where I can specify the dev id and password, from where the brightscript plugin and pull when it run for the first time?

I tried re-installing different versions of eclipse as documented. No luck!
0 Kudos
rtalwar
Level 7

Re: Eclipse Brightscript Plugin Error

I also faced the same issue on both windows and Mac platform with newly released Eclipse plugin.
I had to revert to previous installation.
0 Kudos
sonnykr
Level 7

Re: Eclipse Brightscript Plugin Error

How to revert to old plugin? I mean, when I install new software, and give the plugin url, doesnt it always install the latest version?
0 Kudos
rtalwar
Level 7

Re: Eclipse Brightscript Plugin Error

I had the whole zip package ( including Eclipse and Plugin ) backed up with prev installation. I deleted the new one on facing errors and reverted back to old one.
I think Roku should verify the issue being reported here and revert back to old BrightScript plugin meanwhile.

Alternatively you can use makefile to sideload the channel as described in the section 7.3 of this link

http://sdkdocs.roku.com/display/sdkdoc/Developer+Guide#DeveloperGuide-72ApplicationInstallerPage
0 Kudos
EnTerr
Level 8

Re: Eclipse Brightscript Plugin Error

You guys need to talk to malloys about that. Or forsake over-complications and go rogue, eclipse-free.
0 Kudos
NewManLiving
Level 7

Re: Eclipse Brightscript Plugin Error

"EnTerr" wrote:
You guys need to talk to malloys about that. Or forsake over-complications and go rogue, eclipse-free.


He was or still is on vacation. Started out with eclipse from the beginning
Always used An IDE. Can't even imagine coding the 2D API without it
Just too code intensive. Everything I need including graphics, my own Libs
XML, JSON , audio, video, editors are accessible through it right in the
Project manager. When I want to move to
Fire tv dev I just change perspectives. Until something better comes along
It is well worth the the minor bugs that can be worked out. However,
Releasing the 6/27 plugin without any info was probably not the best
Idea. It is a little more buggy but has some nice features
My Channels: 2D API Framework Presentation: https://owner.roku.com/add/2M9LCVC
Updated: 11-11-2015 - Completed Keyboard interface
The Joel Channel ( Final Beta )
0 Kudos
malloys
Level 7

Re: Eclipse Brightscript Plugin Error

Hey guys,

I'm on vacation, but will be back and checking into this and other issues on Thursday.
In the meantime, it's possible to rollback to the previous eclipse configuration (and therefore the previous plugin version) - just google "eclipse rollback update" and you'll find various explanations on how to do so.
0 Kudos