Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
rynop
Level 7

Roku Premiere hang and no logging

I have a screen graph application that works fine on Roku 2 and the new Roku Streaming stick.  The same zip deployed to the new Roku Premiere hangs when trying to load content into a RowList.

My Roku Premiere is only firmware 7.2.2.  My streaming stick is 7.5 (not sure what the Roku 2 is, as it is at home right now and I am at work).

I telnet to the Premiere and I get no errors.  The screen freezes and I have to press the reset button on the bottom of the premiere.

Another thing I notice on the premiere is my "print" statements on the render thread do not make it to the telnet output.  Print statements in my main thread work just fine.  I have a print statement in my component "init" method that does not get printed out.  This print statement is before the RowList content is changed (its the 1st statement in my components brs file).

Is there some known issue with screengraph and firmware 7.2?  Or some known issue with Premiere?

We are trying to bring quite a few roku apps to market and this is a serious issue for us
0 Kudos
4 Replies
EnTerr
Level 8

Re: Roku Premiere hang and no logging

Sounds like a "dreadlock" issue. They did change how thread locks work between 7.2 and 7.5, in particular rendezvous timeout. The bug is likely in your code, not accounting for dreadlocking.

To pinpoint, pepper your code liberally with print statements - don't be frugal on them electrons. Before field assignment, after field assignment - carpet bomb that code. And btw, the remote reboot combo (HHHHHU<<>>) should work.

When i get in a pickle like that, i don't even bother with proper texts - it will be removed - i just do "? 1", "? 2" and so on. I tend to bisect - add more diagnostic as i zero-in on the exact place... there are infinities of numbers between 1 and 2 (meet the Dewey library classification - 1.5, 1.3, 1.4, 1.45... Smiley LOL)

Keep us posted on the discovery/
0 Kudos
rynop
Level 7

Re: Roku Premiere hang and no logging

Thanks for the reply.  I was not aware of https://sdkdocs.roku.com/display/sdkdoc/Debugging+Scene+Graph+Applications until this am.  It helped in that I am now seeing an error in the Render thread on the premiere that is not present in the 7.5 firmware.  There is some strange timing issue where `m.top.findNode("myElementID")` in the render thread code is returning invalid in 7.2 but not in 7.5.  Once I figure out what is going on I will def report back here.
0 Kudos
EnTerr
Level 8

Re: Roku Premiere hang and no logging

Ok, that's exactly what you are experiencing - dreadlocks time out in 7.2.
The "Debugging Scene Graph Applications" is pretty useless on that but read here #SceneGraphThreads-TaskNodeThreadRendezvousTimeout on the worst RSG nightmare
0 Kudos
rynop
Level 7

Re: Roku Premiere hang and no logging

Thanks. Yikes that is not cool at all.
0 Kudos