Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
iptvmag
Level 7

ROKU 4 Compatibility

I developped an application which is working perfect on roku 3, but i am not able to get it working on roku 4k.
I there any special configuration?, resolution 1080p, i am not using any 4k content
0 Kudos
9 Replies
EnTerr
Level 8

Re: ROKU 4 Compatibility

be specific, pls - in what ways does it "not work"?
have you checked the telnet console for error messages?
0 Kudos
iptvmag
Level 7

Re: ROKU 4 Compatibility

It does not work it mean does not install. I think the issue is that ROKU premiere has been downgrader to os 7.2.2 due to issues in OS 7.5. and my application is built using new functions and methods from OS 7.5
0 Kudos
EnTerr
Level 8

Re: ROKU 4 Compatibility

What do you mean, "does not install": what's the specific error in the uploader and/or console?
0 Kudos
iptvmag
Level 7

Re: ROKU 4 Compatibility

There is no error. It does not install it means when you send it using the private channel code it does not show in the list because it is built using OS 7.5 functions that are not available in 7.2.2 version
0 Kudos
EnTerr
Level 8

Re: ROKU 4 Compatibility

No, no - it doesn't work like that, for testing you don't add the channel with vanity code - you have to side-load the ZIP instead to be able to see diagnostics in the console! 

Be methodical, do that before painting conclusions with a broad brush ("it does not show in the list because it is built using OS 7.5 functions that are not available in 7.2.2 version" - i heard you speculating the first time but if that's the case, there'd be evidence exceptions in the console).
0 Kudos
iptvmag
Level 7

Re: ROKU 4 Compatibility

For testing i use sideload or eclipse export and i get an error unable to install.

When adding the channel using the code it installs but when you open it you get a black screen, it is only doing it on OS 7.2.2, with OS 7.5 it works in both cases with no error
0 Kudos
EnTerr
Level 8

Re: ROKU 4 Compatibility

Sorry, we are having some communication problem here. I'll try again:
What is the error message in the telnet 8085 console when you try and install the ZIP via sideloading?
Besides "unable to install" ecliptical, there should be more diagnostic text in the console.

If still unclear, for troubleshooting purposes feel invited to close Eclipse and follow the side-loading instructions at the link i provided above.
0 Kudos
iptvmag
Level 7

Re: ROKU 4 Compatibility

I got your question, there is no console error.

Do you believe that an application using functions available only in OS 7.5 and up will work on OS 7.2.2?

I dont have access to a roku wth OS 7.2.2 now, as soon as i get one i will double check if there was any console error, but the application does not crash it is just not loading.

Thank you
0 Kudos
EnTerr
Level 8

Re: ROKU 4 Compatibility

"iptvmag" wrote:
Do you believe that an application using functions available only in OS 7.5 and up will work on OS 7.2.2?

Based on my experience, I believe that such an app will have a very clear compile-time (most likely, per your description) or runtime error message in the console.
0 Kudos