Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
greubel
Level 8

Multiple tracks and 5.1 surround sound

This is from one of my users:

Okay folks... problem found. The Roku does NOT like files with multiple audio streams AT ALL. I have now removed ALL audio streams from my test files, encoded with handbrake at bitrates in excess of 3.5MBPS (afraid to go higher for standard DVDs as the file size will exceed the original DVD size) and there is ZERO stutter, the file plays in 5.1 without drop outs, etc. The second I add a 2nd audio track, regardless of position, type, etc., the 5.1 signal will not play properly and there will be constant reloads that are often unrecoverable (freeze the machine). This is a huge problem and MUST be fixed by Roku. It basically means that, for most people, they will have to keep multiple versions of their videos if they want to encode for an TV and a separate file for Iphone, Ipod, iPad, etc.... ridiculous...
0 Kudos
7 REPLIES 7\
RokuKevin
Level 9

Re: Multiple tracks and 5.1 surround sound

Have you tested this content against v2.8 or v2.9? If so, please point me to the problematic stream.

Thanks,

Kevin
0 Kudos
greubel
Level 8

Re: Multiple tracks and 5.1 surround sound

Download from user and tried on 2.9
Three videos are here - > http://www.chaneru.com/Roku/Lee/

1. This video Works AC3 Pass only audio track - 3500kbps.m4v
http://www.chaneru.com/Roku/Lee/This%20video%20Works%20AC3%20Pass%20only%20audio%20track%20-%203500k...

2. This video Works but only in stereo track 2 and 2 audio tracks - 2500kbps.m4v
http://www.chaneru.com/Roku/Lee/This%20video%20Works%20but%20only%20in%20stereo%20track%202%20and%20...

3. This video does not work at all - track 2 is AC3 passthru with 2 total audio tracks - 2500kbps.m4v
http://www.chaneru.com/Roku/Lee/This%20video%20does%20not%20work%20at%20all%20-%20track%202%20is%20A...
0 Kudos
RokuKevin
Level 9

Re: Multiple tracks and 5.1 surround sound

Thanks for the examples. I've got a busy day today, but will try these out next week.

--Kevin
0 Kudos
rraheja
Level 7

Re: Multiple tracks and 5.1 surround sound

Any update on this? just hit this issue when converting all my movies and videos to play on Roku XD with the latest firmware. With the default Handbrake High Profile with two audio tracks (first AAC Dolby Prologic and second AC3 Passthrough) there is no audio at all. With either one it works fine! Would hate to keep two copies of everything - Roku, please fix!
Thanks!
0 Kudos
RokuKevin
Level 9

Re: Multiple tracks and 5.1 surround sound

We've modified the firmware in an upcoming release to select the audio stream based on the audio mode setting of the box. The AC3 vs AAC audio stream selection is fixed and I've tested it against all these sample streams. Will be released to end users soon...

--Kevin
0 Kudos
Jabroni2122
Level 7

Re: Multiple tracks and 5.1 surround sound

Awesome I'm glad to hear this is getting fixed, any further update for us, or idea when one might come out? I know some things take a while, so I can wait, but I have no Idea if it will be a week or a year, or exactly how to update when it does come? I'm at 2.9 right now, I've tried updating in settings, player info, and it says my software is up-to-date. Is that all I need to do to update? I'm also still having trouble's playing videos with the multi audio tracks, so this issue must not be fixed yet.

Some of my movies will load and play with no sound at all and then after a minute or so try to reload and get stuck, others come up with the message "An unexpected problem (but not server timeout or HTTP error) has been detected". At first I was trying to play my movies in USB Media Browser, now I've been trying it in Roksbox, because I like the way that channel is set up. These movies are formatted with both AC3 Passthru first, and then AAC.
0 Kudos
RokuKevin
Level 9

Re: Multiple tracks and 5.1 surround sound

If you private message me your SN I can get you on a v2.9 patch beta build that includes this fix.

--Kevin
0 Kudos