Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
simranjit
Level 8

Channel version is different from the Store Version

While uploading channel on Roku Store an error is showing :
"Channel version in the manifest is different from channel-associated data in Channel Store DB."

Channel version is 2.3.3
Store version is 7.6

How to correct this error, can we decrease the store version to 2.3?
0 Kudos
6 Replies
speechles
Level 9

Re: Channel version is different from the Store Version

You would need to make a new developer ID on that Roku. Run genkey again. Then upload your zip to that Roku. Use the developer console to download the signed PKG from that Roku. Now that package can overwrite your existing one and be 2.3 and it will not complain. The registry will not carry over since you changed developer ID.

That is the problem you are having. If you use the same developer ID on your app you cannot roll back versions as it will think you are making a mistake. Version updates go up, not down. Smiley Happy
0 Kudos
simranjit
Level 8

Re: Channel version is different from the Store Version

"speechles" wrote:
You would need to make a new developer ID on that Roku. Run genkey again. Then upload your zip to that Roku. Use the developer console to download the signed PKG from that Roku. Now that package can overwrite your existing one and be 2.3 and it will not complain. The registry will not carry over since you changed developer ID.

That is the problem you are having. If you use the same developer ID on your app you cannot roll back versions as it will think you are making a mistake. Version updates go up, not down. Smiley Happy

Thanks.
But while uploading pkg file to Store, I am not able to update the Channel version to 2.3 
While selecting "Select a version for your channel", I can select a minimum of 7.0 only. How can we update the channel version to 2.3 ?
Uploading pkg file to "https://developer.roku.com/developer-channels/channels/edit/packageUpload".
0 Kudos
speechles
Level 9

Re: Channel version is different from the Store Version

"simranjit" wrote:
"speechles" wrote:
You would need to make a new developer ID on that Roku. Run genkey again. Then upload your zip to that Roku. Use the developer console to download the signed PKG from that Roku. Now that package can overwrite your existing one and be 2.3 and it will not complain. The registry will not carry over since you changed developer ID.

That is the problem you are having. If you use the same developer ID on your app you cannot roll back versions as it will think you are making a mistake. Version updates go up, not down. Smiley Happy

Thanks.
But while uploading pkg file to Store, I am not able to update the Channel version to 2.3 
While selecting "Select a version for your channel", I can select a minimum of 7.0 only. How can we update the channel version to 2.3 ?
Uploading pkg file to "https://developer.roku.com/developer-channels/channels/edit/packageUpload".

You need to change your developer ID with GENKEY on that Roku that is creating the PKG you are downloading from that Roku. That PKG you have that you upload to Roku has a developer ID that has already uploaded a version to that app-ID. Each new version must be the same or higher. Not lower.

To go lower you must change your developer ID for that application. It then sees it as a new application for that app-ID. Then upload a new PKG with any version number you want.
0 Kudos
OddScott
Level 7

Re: Channel version is different from the Store Version

My understanding is that this particular "Static Analysis" error is harmless, and can be ignored unless someone at Roku complains after the channel's package file has been submitted for approval.

That said, if you still want to eliminate the error, I believe all you need to do is to match the major and minor version numbers in the channel's manifest to the Version Number in your Roku Developer Account: https://developer.roku.com/docs/developer-program/getting-started/architecture/channel-manifest.md.

For example your current manifest probably contains:
major_version=2
minor_version=3
build_version=3


If the store version is 7.6, change the manifest major_version and minor_version numbers to the following and the error should go away (build_version can be whatever you want):
major_version=7
minor_version=6
build_version=3


No need to change the channel's Dev ID and the registry is not affected.
www.InstantTvChannel.com - Build a Roku channel in 5 minutes!
0 Kudos
simranjit
Level 8

Re: Channel version is different from the Store Version

"speechles" wrote:
"simranjit" wrote:
"speechles" wrote:
You would need to make a new developer ID on that Roku. Run genkey again. Then upload your zip to that Roku. Use the developer console to download the signed PKG from that Roku. Now that package can overwrite your existing one and be 2.3 and it will not complain. The registry will not carry over since you changed developer ID.

That is the problem you are having. If you use the same developer ID on your app you cannot roll back versions as it will think you are making a mistake. Version updates go up, not down. Smiley Happy

Thanks.
But while uploading pkg file to Store, I am not able to update the Channel version to 2.3 
While selecting "Select a version for your channel", I can select a minimum of 7.0 only. How can we update the channel version to 2.3 ?
Uploading pkg file to "https://developer.roku.com/developer-channels/channels/edit/packageUpload".

You need to change your developer ID with GENKEY on that Roku that is creating the PKG you are downloading from that Roku. That PKG you have that you upload to Roku has a developer ID that has already uploaded a version to that app-ID. Each new version must be the same or higher. Not lower.

To go lower you must change your developer ID for that application. It then sees it as a new application for that app-ID. Then upload a new PKG with any version number you want.

Thanks Smiley Happy
0 Kudos
simranjit
Level 8

Re: Channel version is different from the Store Version

"OddScott" wrote:
My understanding is that this particular "Static Analysis" error is harmless, and can be ignored unless someone at Roku complains after the channel's package file has been submitted for approval.

That said, if you still want to eliminate the error, I believe all you need to do is to match the major and minor version numbers in the channel's manifest to the Version Number in your Roku Developer Account: https://developer.roku.com/docs/developer-program/getting-started/architecture/channel-manifest.md.

For example your current manifest probably contains:
major_version=2
minor_version=3
build_version=3


If the store version is 7.6, change the manifest major_version and minor_version numbers to the following and the error should go away (build_version can be whatever you want):
major_version=7
minor_version=6
build_version=3


No need to change the channel's Dev ID and the registry is not affected.

Thanks Smiley Happy
0 Kudos