Roku Developer Program

Join our online forum to talk to Roku developers and fellow channel creators. Ask questions, share tips with the community, and find helpful resources.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mbenedict261
Channel Surfer

Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

My channel has been up and running ever since the sunsetting of Direct Publisher. Without warning, when someone clicks the "Play" button, they get the following error:

error:bad:transfer error: couldn't use specified SSL cipher response code:(0):extra:etype:buffer

Any ideas? I'm trying to look in this forum and google, but there isn't a lot of support for Brightscript/Roku... so it is difficult to find any answers.

0 Kudos
1 Solution

Accepted Solutions
mbenedict261
Channel Surfer

Re: Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

I figured out what the issue was, just in case anyone is having the same issue. My home provider (where I do my development) is Xfinity. They recently introduced xFI Advanced Security. That was the issue. I turned it off on my account and I no longer get that message.

I'm going to contact them to add an exception for my cloud host so I can turn that security back on, but still be able to access my videos.

 

View solution in original post

0 Kudos
7 REPLIES 7
RokuBen
Community Moderator
Community Moderator

Re: Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

Did something change in the webserver configuration for the site you're loading content from?  This is the CURLE_SSL_CIPHER code from libcurl that can't negotiate a SSL connection to start downloading data associated with the video.

mbenedict261
Channel Surfer

Re: Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

Ah... I don't think so, but it's a good place to start looking. Thanks a ton for your response.

0 Kudos
mbenedict261
Channel Surfer

Re: Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

Everything I can find in the documentation, installing and using the SSL Certificate, all relates to getting the feed. I can't find anything on this error, or what I have to do that will have any effect on this error. I put in a message to the video host, but I'm not optimistic lol

0 Kudos
mbenedict261
Channel Surfer

Re: Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

I figured out what the issue was, just in case anyone is having the same issue. My home provider (where I do my development) is Xfinity. They recently introduced xFI Advanced Security. That was the issue. I turned it off on my account and I no longer get that message.

I'm going to contact them to add an exception for my cloud host so I can turn that security back on, but still be able to access my videos.

 

0 Kudos
RokuBen
Community Moderator
Community Moderator

Re: Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

Wow, that's a potential problem for lots of Roku devices.  I'll alert our internal teams.

RokuBen
Community Moderator
Community Moderator

Re: Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

Looking at the description at https://www.xfinity.com/support/articles/online-security-with-xfi-faqs, it looks like it might be taking DNS names that are hosts that have had problemtic content and is redirecting them to a "deny" server. That would cause certificate problems.  Do you know if the video content you were pulling was from a host that could be on their block list?

0 Kudos
mbenedict261
Channel Surfer

Re: Channel just began throwing error: Couldn't use specified SSL cipher response code (0)

Jump to solution

That was the exact document I stumbled on when I realized that the issue wasn't happening for everyone and I thought it might be an issue of provider. I assume the domain name was on a block list, since when I turned off the Advanced Security for my home account, the channel worked as it should have. I use pCloud to host my videos and I submitted the domain https://filedn.com for them to review and hopefully take off the list.

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.