Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Roku white steady light. Not responding at all

I actually uses my roku for like 2 months. One day, it stopped working. The tv screen went “no signal” and the roku light was steady white. I pressed every button in the remote control and it didnt even blink. I changed de hdmi cable, i changed the batteries from the remote, i tried in a different tv. Nothing worked. So i got tired and left.
Some months later i tried again. I connected it and it worked. But for 2 minutes. It went off again. White steady light. No signal on the tv and no response.
No one could ever give me an answer
0 Kudos
7 Replies
Highlighted
Level 19

Re: Roku white steady light. Not responding at all

Hi there! 

Thanks for reaching out. Have you tried performing a full factory reset on the device using the hardware button on the back/bottom of the unit? Take a look for more instructions on how to perform the reset: 

https://support.roku.com/contactus

Thanks,
Tanner
0 Kudos
Highlighted
Level 7

Re: Roku white steady light. Not responding at all

I have got the same problem with the Roku ultra not sending a signal to the tv. I have tried to factory reset by following your steps but nothing works. My Roku is only 2-days old, my 4k tv is brand new. HDMI cable is new. Several people have encountered similar issues but there seems to be no solution.

Highlighted
Level 7

Re: Roku white steady light. Not responding at all

I'm having the exact same problem! I've only had my Roku Streaming Stick + for 2 months and it just quit working and the light is a solid white and I've done everything from the reset button on the stick to changing out batteries and just unplugging everything. I've done everything I could research online and it still isn't working. With it only being 2 months old this is unacceptable for it to stop working no matter what I do. I've got the "no signal" message on every TV that I tried it on and I've changed out the USB cord as well. I don't know what else to do but it's very frustrating to pay for it and not be able to use it for longer than 2 months!

0 Kudos
Highlighted

Re: Roku white steady light. Not responding at all

I have the exact problem described as well. It worked fine for 6 months then froze. Multiple attempts to factory reset have done nothing. The white light stays on and steady from the time it gets power. I've tried multiple HDMI ports, TVs, cables (which work fine for other devices). My remotes are functioning and have fresh batteries. Has anyone had any luck finding a solution? Is there somewhere to send the device for repair or get a new board? Thanks for your help.

0 Kudos
Highlighted
Level 7

Re: Roku white steady light. Not responding at all

I had the same issue mine stopped turning on today. I can use the remote to turn my tv off or on and change the volume but I can't get the roku to turn on. Before today I keep getting messages about power and I used everything they sent me with it. I got mine 2 months ago and I never even dropped the remote and it went out. It's kinda bad that I paid for a product that won't work. Will roku send us our money back ? Will they replace my roku streaming stick plus? Will they pay for all my accounts that I can't use right now due to they error? I need answers 

0 Kudos
Highlighted
Level 19

Re: Roku white steady light. Not responding at all

The first thing to try is new batteries in your remote.  It appears your remote is no longer paired with your stick.  For warranty information:

https://support.roku.com/article/208757058-Step-by-step-instructions-for-returns-and-warranty-replac...

0 Kudos
Level 7

Re: Roku white steady light. Not responding at all

I am having the same problem. My roku express + worked for about a year and then randomly stopped. I have tried resetting it, new hdmi cable, unplugging and plugging cords, everything I have been told to try. Please help 

0 Kudos