Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
reallimey
Level 7

Loss of Multi Channel audio on Premier + 4630R after 9 update

My Premier + was updated recently to version 9. After this happened I noticed that I can no longer get Multi Channel sound. I choose it in the settings, but when I enter Netflix, whatever show I enter the 5.1 sound is not available. none of my other apps output multichannel either, just stereo. the connection has not changed and it was outputting 5.1 perfectly before the upgrade. What needs to be done to fix this? I have restarted the roku multiple times without any success.

Please advise urgently
0 Kudos
5 Replies
atc98092
Level 13

Re: Loss of Multi Channel audio on Premier + 4630R after 9 update

Check your audio settings (using the * button) and see if sound leveling or night mode is enabled. If so, those force stereo sound, so turn them off. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
reallimey
Level 7

Re: Loss of Multi Channel audio on Premier + 4630R after 9 update

I tried that in Netflix and no change, but as stated its not just Netflix. I am getting no multi channel from any apps. Amazon, Plex, Vudu everything is stereo only.
0 Kudos
Community Manager
Community Manager

Re: Loss of Multi Channel audio on Premier + 4630R after 9 update

@reallimey
Thanks for reaching out. Sorry to hear about the issue you're running into! 

- What is your current device connection configuration? (Is your Roku device connected directly to your A/V receiver, which is then connected to the TV? Or, is the Roku device connected directly to your TV, which is then connected to the A/V receiver via HDMI/ARC?) 
- Have you tried reversing your configuration (based on the two options above) to see if this resolves the issue you are seeing? 
- What is the specific make/model of A/V receiver you are using?
- What is the specific make/model of TV you own? 

Please PM me with your Roku account email address and the serial number of your device from Settings>Suystem>About. I can assist you further from there! 

Thanks! 
Tanner
Tanner D.
Roku Community Manager
0 Kudos
sdsalsero
Level 7

Re: Loss of Multi Channel audio on Premier + 4630R after 9 update

I have the same issue -- Premiere+ with Roku OS 9.0, no longer get surround-sound. I noticed it on my DTS videos in the Plex app. Plex says that Roku is reporting that it is not compatible, and if I force Plex to send the original DTS stream there is no sound. My Yamaha AVR supports DTS so the Roku appears to be blocking it, no pass-through.

I also checked all the following settings:
- Audio = Auto, D+ DTS
- HDMI = 1080p HDCP 1.4

I no longer see a night-mode for Audio?
_____________
FIXED
From browsing this forum I read about how the Night Mode is now controlled through the playback menu (start a video, then press * key). Night Mode was enabled in that menu, and when I toggled it off, then restarted the video -- DTS worked!
0 Kudos
Dreamfield42
Level 7

Re: Loss of Multi Channel audio on Premier + 4630R after 9 update

"sdsalsero" wrote:
I have the same issue -- Premiere+ with Roku OS 9.0, no longer get surround-sound. I noticed it on my DTS videos in the Plex app. Plex says that Roku is reporting that it is not compatible, and if I force Plex to send the original DTS stream there is no sound. My Yamaha AVR supports DTS so the Roku appears to be blocking it, no pass-through.

I also checked all the following settings:
- Audio = Auto, D+ DTS
- HDMI = 1080p HDCP 1.4

I no longer see a night-mode for Audio?


I believe it's called sound leveling.
_____________
FIXED
From browsing this forum I read about how the Night Mode is now controlled through the playback menu (start a video, then press * key). Night Mode was enabled in that menu, and when I toggled it off, then restarted the video -- DTS worked!
0 Kudos