Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
luxlunae
Level 7

Brutal Interface lag on my Roku since the Dec update

Anyone know how to troubleshoot this? I have terrible lag, usually 5-20 seconds between pressing a button on the remote and anything happening. Sometimes it will work just fine for a few seconds, and then stop responding while the hand is in the same location. There are no problems with the power/volume features and this isn't a positioning issue. It's much worse on the home screen and this is a sudden problem that has started in the last month, after the December update. 

I've loved my rokus for... at least 3 years, but this is just unbearable.
0 Kudos
3 Replies
jeffrok
Level 12

Re: Brutal Interface lag on my Roku since the Dec update

What model of Roku do you own?

Sometimes the new updates are too much overhead for the older Roku's, causing them to run more slowly then before.. I experienced this with my Roku 2 XS, before replacing it with a Roku 3.

You may have had your Roku box for 3 years, but was it a new model at the time?
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
0 Kudos
luxlunae
Level 7

Re: Brutal Interface lag on my Roku since the Dec update

I believe this is my newer roku, 3800X and less than a year old. 

It also had some overheating issues in December, could that cause input lag? (I switched to an external power source after the overheating and it didnt' happen again). Today I went back to plugging it in the back but the horrible lag continued. 
0 Kudos
Smokindog
Level 9

Re: Brutal Interface lag on my Roku since the Dec update

I really see this on my 2018 Stick and Stick+.  There is also a noticeable change to start up times.  I power these devices from the TV USB port so they shut down when the TV is turned off.  It takes a LOT longer  for these devices to acquire and connect to the WiFi and there's a lengthy delay to recognize the remote.  All started sometime in December.

The 2018 Ultras also are slower.  The last update also did something that caused compatibility in the wired networking with a particular make/model of Gb switch.  Performance dropped to 1-3Mbps.  I tried 2 of the same make/model, one was NIB.  Swapped it for a different make/model switch and all was well again (90+ Mbps).  The original switches worked fine elsewhere and yes I did all the "classic" cable/wiring checks too, all relatively new CAT6 or better Smiley Happy  For you "older folks" it was like the address cache issues caused between certain makes of hubs/switches in the early 10/100 days Smiley Wink
Brought to you from someplace in Texas!
0 Kudos