Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jubileigh
Level 7

Audio OFTEN goes missing ONLY when trying to play surround sound.

Audio OFTEN goes missing ONLY when trying to play surround sound (when I set ROKU audio setting, both "AUDIO" and HDMI" settings are set to AUTO).

When the audio gone missing, it will be missing for all contents (Youtube, Netflix etc) and I have to restart the ROKU to get the sound back.

As indicated in ROKU troubleshooting guide, this problem indeed will go away when i changed both "AUDIO" and HDMI" settings are set to STEREO, however this solution is not acceptable since I won't able to benefit from the Surround Sound.

I am using Samsung QR90R Soundbar which support Dolby Digital Plus and Dolby Atmos.

And I am using Belkin latest HDMI cable to connect my Roku Ultra to the Soundbar.

FYI I encountered the same problem when I tried with the TV Speakers also.

 

In addition to ROKU Ultra, I also have Apple TV 4K and I can enjoy Dolby Atmos on my Soundbar with it.

Kindly help to look into this problem and advise me accordingly.

0 Kudos
1 REPLY 1\
boogernose
Level 18

Re: Audio OFTEN goes missing ONLY when trying to play surround sound.

I'm sure this will piss you off....

But, I'm a bit of an Audiophile and I gave up on 5.1 and the 7.1 fads along time ago.

I think Stereo is second to none. Especially with nice equipment.

If you had all your speakers running on two channels you might agree.

Of course you might not get that effect of your head being blown off but I think it sounds great.

---A problem clearly stated is a problem half solved---.
0 Kudos