Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
STG0527
Level 7

Amazon App Issues

Jump to solution

I've been having audio playback issues with Amazon app/channel. The audio isn't in sync with the video, you hear them speak before or after their mouths move. This is the only app/channel that I'm having this issue with. Is there something going on with Amazon/Roku? I tried restarting everything and re-downloaded the app and it's still doing the same thing. Is there a fix for this?

Lord Hand, Hand of the Queen
0 Kudos
1 Solution

Accepted Solutions
makaiguy
Community Streaming Expert

Re: Amazon App Issues

Jump to solution
When removing/reinstalling, did you restart your Roku between uninstalling and reinstalling? This will make sure there is nothing hanging around in memory from the original installation so that everything for the channel gets reinstalled. It may not make a difference, depending on the exact nature of your problem, but it's worth trying.
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee, just a user like you.

View solution in original post

2 Replies
makaiguy
Community Streaming Expert

Re: Amazon App Issues

Jump to solution
When removing/reinstalling, did you restart your Roku between uninstalling and reinstalling? This will make sure there is nothing hanging around in memory from the original installation so that everything for the channel gets reinstalled. It may not make a difference, depending on the exact nature of your problem, but it's worth trying.
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee, just a user like you.

View solution in original post

STG0527
Level 7

Re: Amazon App Issues

Jump to solution

Restarting in between seemed to do the trick. Thank you!

Lord Hand, Hand of the Queen
0 Kudos