Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jonpaladin
Level 7

Roku TV and Google Nest WiFi don't get along

I have a Roku TV made by Best Buy's Insignia brand that I purchased in 2018.

I have a Google Nest WiFi Router that I purchased and set up in the beginning of April. It is brand new.

I never previously had a problem with the TV connecting to networks. It still connects to my phone's wifi hotspot if necessary.

Several devices--androids and iphones, several windows/linux/chromecast laptops, other google devices--are connected to my Google WiFi with absolutely no problem.

For some reason, though, the TV won't connect to the Wifi. I have tried to go through Roku customer service and Best Buy/Insignia customer service. Google doesn't really have customer service because they are awful.

But anyway, I took it as far as resetting my TV to factory settings and it still won't connect. It sees the network but won't connect after I enter the password. It's the same error code before and after I regrettably reset it: 014.3.

Needless to say, this is extremely annoying and stupid and wasting a ton of my time. Does anyone have any idea how to address this issue?

5 Replies
Korell
Level 7

Re: Roku TV and Google Nest WiFi don't get along

I am also facing this issue. I even tried setting up via the Roku all by using the Connect Manually feature and using the Roku TV's IP address--this did not work. 

0 Kudos
rpm17
Level 7

Re: Roku TV and Google Nest WiFi don't get along

Had the same problem with a newly installed Nest WiFi and Roku devices not connecting. Had to cut on hot spot from my phone and rename the phone hotspot to the Nest router name and change the password on the hot spot the same as the Nest router. That way the Nest WiFi and my hotspot had identical names and passwords. Unplug the Nest router and scan networks in Roku. Look for the hotspot which will show up as the same name as your router. Roku should connect with credentials for hotspot. Turn hotspot off and plug in the Nest WiFi. Roku device should keep the connection based on the same name and password. Info came from Google support.

Tags (1)
Jaybee
Level 7

Re: Roku TV and Google Nest WiFi don't get along

I had the same issue.  I have been using a TCL Roku TV and an Onn Roku TV with Google Nest WiFi with no issues for a few months. One day I tried turning both TVs on, neither worked.  They Worked fine hard wired to Router but not thru Nest.  Roku would recognize and connect to my Nest, showed excellent signal strength, but every time I clicked an App to watch, I would get an error code or it would simply return right back to the Home Screen. I tried the method of using the hotspot and mimicking the router name and PW on the hotspot, didn’t work for me.  I finally did a full factory reset on the Nest WiFi and started from scratch setting it back up.  That worked for me. Hallelujah.   Very frustrating though. 

0 Kudos
playku
Level 7

Re: Roku TV and Google Nest WiFi don't get along

Add me to the list of unfortunate Roku/GoogleWiFi owners. Noted succcess story involving factory reset of Google network. I suppose I will try that. 

Tags (2)
0 Kudos
AvsGunnar
Level 10

Re: Roku TV and Google Nest WiFi don't get along

@playku 

If the resets don't work for you, will most likely have to verify your network settings (mainly channel selection and assignment) from within the router settings are setup to recognize Roku.

Using your app or accessing the router settings through browser admin login, you need to determine what channels your network (wi-fi) is currently operating on.  For the 2.4 ghz band, you should get a result between 1 and 11 for the channel.  For the 5ghz band, you should get a result between 36 and 165. 

Once you determine your configuration, you may need to change the settings to reflect the below recommended settings to get Roku to connect.

Basic Router/Network Configuration for Roku Devices (Wireless Settings)

2.4gz network band..... Radio Enabled/On, set Channel between 1-11, not Auto, 12, 13, or 14, Protocols/Mode set to b/g/n, Bandwidth 20Mhz.

5gz network band..... Radio Enabled/On, set channel 36-48 or 149-161, not Auto or any channel 52thru140, Protocols/Mode set to N/AC, Bandwidth 20mhz or 40mhz(preferred) or 20/40.

If you need more help, post back with your router model number and the specific Roku models you have and a little more detail with the exact problems you are having, and any error codes on screen you may be seeing.

0 Kudos