Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Problem setting display to 4k

I recently bought a Roku Premiere but am having trouble setting it up with 4K resolution. My Samsung tv says that all 4 ports it has are HDMI 2.0, and support HDCP 2.2. However, when I try to set it up at 4K 60hz or 4K 30hz it tells me that HDCP 2.2 is not supported. I am using the HDMI that was included with the Roku, and have contacted Samsung support to make sure my HDMI ports are capable of supporting HDCP 2.2 

Not sure what else to do so any help would be appreciated

0 Kudos
7 Replies
Level 21

Re: Problem setting display to 4k

On Samsung 4K TVs you must enable UHD Color on each HDMI input you want to connect a 4K/60 device. I forget exactly where the setting is in the Samsung menu, but look around and you'll find it. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Level 7

Re: Problem setting display to 4k

Thanks for the reply!
So I did manage to find where I can enable UHD for my HDMI ports, but I’m still having the same problem. When I try to set up with 4K I get a check mark for the “4K at 60fps” but an x for HDCP 2.2.  Any other ideas?

0 Kudos
Level 21

Re: Problem setting display to 4k


@Forbesyyy wrote:

Thanks for the reply!
So I did manage to find where I can enable UHD for my HDMI ports, but I’m still having the same problem. When I try to set up with 4K I get a check mark for the “4K at 60fps” but an x for HDCP 2.2.  Any other ideas?


I'd next try a different HDMI cable. Always possible you received a defective one. Make sure it's certified for 18 Gbps speed. Ignore any labels that claim to be HDMI 2.0, as there's no such thing. HDMI is HDMI, it's only their speed rating that has any validity. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Level 7

Re: Problem setting display to 4k

I tried swapping it with my ps4 pro HDMI cable and I still get the same result. 

0 Kudos
Level 21

Re: Problem setting display to 4k

I'm at a loss then. I have three different 4K Roku players (2 Ultras and a Premiere) and have never encountered an HDCP error. Perhaps @RokuDanny-R or @RokuTannerD can assist. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Level 7

Re: Problem setting display to 4k

Thanks for trying!

0 Kudos
Level 7

Re: Problem setting display to 4k

Hey, I just wanted to chime in on this one since it helped me and maybe could help others.

I was in the same boat.  I have a 2016 Samsung KU6000 which is a 4k tv and apparently now has HDR capabilities (originally it wasn't in the menu, but assuming a firmware update change it, now it is).  

I was considering getting a new tv for appletv capability and was reviewing my current setup.

Well rather than the hassle of getting a new TV, selling my old one, installing and setting up a new one, I'm happy to say i've decided to stick with my old samsung and am very happy after making a few adjustments.

First, to solve the problem of no appleTV support and a slow smart tv menus, I got the Roku Ultra (awesome!) not to mention I set up other channels, which I didn't have in the built in samsung dashboard.

Second, I actually discovered HDR picture mode in the TV settings.

Third, I was using the roku in in 4k hdr 30hz mode (autodetected), but from this article, I followed the tip to actually enable HDR on HDMI 1 (all were off by default), and low and behold, the roku, in auto picture detection, comes back with 4k hdr at 60hz!  Awesome :-). (yeah, i'm old:-p)

So, in summary, see what newer settings you might have after a firmware update, most importantly get familiar with them, and get a roku :-). (better than the hassle of a whole new bigstreen TV!). Btw, u might also add a solid cable as mentioned to your troubleshooting.  In my case, I tried a much better cable, but it was actually turning on the hdr in settings that did the trick (even after going back to my original thinner cable).

 

0 Kudos