Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

How to turn off sleep mode on Roku Premier

Jump to solution

Is there a way to turn off the sleep mode with the Roku Premier?  Just got it and it drives me crazy that it just turns off whenever!

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Level 16

Re: How to turn off sleep mode on Roku Premier

Jump to solution

Check Settings/Screensaver/Change wait time>>Disable

and or  Settings/Network/Bandwidth saver>>Off

 

Roku Ultra ---Ethernet rules---

View solution in original post

14 Replies
Highlighted
Level 16

Re: How to turn off sleep mode on Roku Premier

Jump to solution

Check Settings/Screensaver/Change wait time>>Disable

and or  Settings/Network/Bandwidth saver>>Off

 

Roku Ultra ---Ethernet rules---

View solution in original post

Highlighted
Level 7

Re: How to turn off sleep mode on Roku Premier

Jump to solution

I will try that.  Thank you so much! New to this. :-)

0 Kudos
Highlighted
Level 7

Re: How to turn off sleep mode on Roku Premier

Jump to solution

Does that work on older Roku models as well?

0 Kudos
Highlighted
Community Manager
Community Manager

Re: How to turn off sleep mode on Roku Premier

Jump to solution

@Go_Go  Thanks for the question. the Bandwidth saver feature is available in OS 9.2 on supported devices that still receive Roku software updates. If you check for updates and none are available, you may have a Roku model that is no longer supported for new updates. Feel free to reach out to me directly if you need further assistance and we'll see how else we can assist you. 

 

Thanks,

Tanner

Tanner D.
Roku Community Manager
Highlighted
Level 7

Re: How to turn off sleep mode on Roku Premier

Jump to solution

I too am having issues with this sleep mode popping up every 10 minutes. I did not set this! Have had the Roku  Premiere for 7 months and this just started coming up only recently.  Have disabled screen saver and bandwidth saver, it still comes up.  The system settings for premiere does not give me a power option as other models of Roku have. Can someone please tell me how to remove sleep mode??? please!. I loathe sleep mode. 

0 Kudos
Highlighted
Level 16

Re: How to turn off sleep mode on Roku Premier

Jump to solution

Are you sure???

Settings/Screensaver/Change wait time>>Disable screensaver

make sure its checked.

Sometimes the software gets stuck.Especially if you have a MicroSD card(remove it temporarily)

If its every 10 minutes its the screensaver not Bandwidth saver.

If youre sure the Screensaver is set to off and still........

Settings/System/System restart>>Restart [or unplug the power for 30 seconds]

and try again.

Good Luck itll work out

 

Roku Ultra ---Ethernet rules---
0 Kudos
Highlighted
Level 7

Re: How to turn off sleep mode on Roku Premier

Jump to solution

Yes, am very sure. There's never been a micro SD card in the unit. Roku Premiere is purely used for streaming and nothing else. Disabled screen and bandwidth saver and I've turned the whole unit off for 30 min. Still sleep mode comes on in he middle of watching a program. Have emailed my cable provider who issued me with the Roku to see if they have any suggestions. Hope to hear from them soon. How can a function just appear without activating it, and now I cannot get rid of it. I'm baffled. I'm thinking I may need to do a factory reset but first want to hear what my provider has to say. Again, any further suggestions are appreciated, and thanks for your suggestions thus far. 

0 Kudos
Highlighted
Level 16

Re: How to turn off sleep mode on Roku Premier

Jump to solution

I dont think we are dealing with Sleep mode per se.

Does a dialog come on the TV that says; "Are you still watching?"

Sleep mode happens every 4 hours.

Something is screwy. What is on your screen when this happens?

Check the settings in your TV as well.

Roku Ultra ---Ethernet rules---
0 Kudos
Highlighted
Level 7

Re: How to turn off sleep mode on Roku Premier

Jump to solution

It's certainly screwy, to say the very least.  Both screen saver and bandwidth saver are off. I don't think it's the screen saver either, as when it goes into this sleep mode behaviour, it always go straight back to the home page - not to any screen saver. A black box with blue print and a 60 second timer says that in that time frame  sleep mode will take effect and to hit any button to stop this. When I haven't been in the room to press any button - sure enough, it's back to the home page. In other words, the timer (sleep or otherwise) constantly stops playback by always taking you to the home page. I have checked my samsung tv and it actually has a sleep timer button which you press to activate/deactivate. This is off and always has been. As I said, when watching free to air tv, no timer issues - only with Roku on. I've been told by one community member that the premiere doesn't even have a sleep timer and yet this box constantly comes up saying sleep timer 60 seconds - press any button. I've now done a factory reset of roku. Will see if that has eradicated the issue. That was the only thing left to do, as I'd tried EVERYTHING else.

0 Kudos