Is your Roku TV not working? Join our online community forum to find help with common Roku TV issues, get troubleshooting tips, and share your experiences.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

All apps stopped working on TCL S535

This has been going on for two days now.

Latest Roku software is installed and the TV is wired directly to my modem. Everything else in the house works fine. Netflix, Prime, YouTube, Pluto etc... every app kinda does the same thing; it'll load to the app's homepage but no specific show will load. No error messages. Tried connecting wirelessly and it's the same problem.

Hoping someone has a great suggestion.

0 Kudos
Community Streaming Expert

Re: All apps stopped working on TCL S535

First, have you tried restarting your TV from Settings->System->Power?  Second, restart all of your network equipment - gateway/modem/router.

If nothing works, it points to a problem with your network even if every other connected device you have is working.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
Reel Rookie

Re: All apps stopped working on TCL S535

I appreciate the quick responses; thank you.

I think I found the solution just minutes after posting, however, I was running out the door. Settings>System>Advanced>Network Connection Reset seems to have fixed the problem. Everything is loading again. 

Hopefully that's the end of this odd hiccup.


0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.