Channel Issues & Questions

Help & troubleshooting for channels on your Roku device, including adding/removing channels, logging in to, authenticating, or activating a channel, channel-specific playback issues, assistance contacting channel publishers to report issues, and adjusting channel-specific settings.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

YouTube purchases won't play

I use YouTube as my primary hub for movie/tv purchases. I tried to watch a previously purchased movie on my Hisense Roku TV through the YouTube app, but when I selected the movie I was kicked back to the Roku home screen.

I restarted the system and tried again. Same thing.

I tried several different purchases. Same thing.

I watched normal, non-purchased YouTube videos just fine.

Any idea what's going and how to fix it? I purchased these movies and tv shows to watch them; and I purchased this TV to watch them on. This apparent disconnect is causing serious problems in achieving that end goal.

0 Kudos
6 Replies
Highlighted
Level 7

Re: YouTube purchases won't play

I have the exact same problem. I go to YouTube on my Roku TV. It tells me to purchase the show on my iphone. I purchase it. but when I go to the show on Youtube on the Roku TV, it keeps saying "something went wrong. This video requires payment to watch". Well, I know it requires payment, and I paid. 

In fact I have paid quite a lot now, to watch shows that won't play on YouTube.

Highlighted
Roku Employee
Roku Employee

Re: YouTube purchases won't play

@charlieg22 

Thanks for the post.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more. 

If the issue remains unresolved, I'd recommend reaching out to Youtube directly to report the issue and request additional support. Many channels on the Roku platform are developed and maintained by the channel provider directly, and they'll be able to best assist. If other channels are working correctly, and you only experience this issue on the Youtube channel (app), that is likely an indication that the issue lies within that particular channel. In these cases, the channel provider will need to investigate the issue in order to help resolve it.  

You can reach them here: https://support.google.com/youtube/?hl=en#topic=9257498

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: YouTube purchases won't play

Encountered this today. I got as far as selecting the movie on my laptop and noticed there was a small blue button on the side to confirm the start of the rental period. This button wasn't showing up on the tv, but I pressed the OK button anyway (on the tv) and the movie started. 

So yeah, just follow the prompts but when you get to a black screen of nothing, just press OK again.

0 Kudos
Highlighted
Level 8

Re: YouTube purchases won't play

I have the same problem; has nothing to do with the requirement for more confirmation per se. In this case, I’ve purchased both seasons of The Orville (for example). I’m able to just watch on YouTube, I’m even able to chromecast to the Roku Ultra. But, navigating in the app through Library -> Purchases and then selecting the specific show does not work.

0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: YouTube purchases won't play

@chunk_split 

Thanks for the post.

For more information about that channel's features and functionality, you'll want to contact Youtube support directly to inquire further. Many channels on Roku are developed and maintained by the channel provider themselves. 

You can reach Youtube support here: https://support.google.com/youtube/?hl=en#topic=9257498

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 8

Re: YouTube purchases won't play

I have had problems for several months with YouTube TV and Google Play not being able to load the channel or play movies.  I went back and fore with Google support who kept telling me it was know bug that had been reported by several other Roku users.  Roku resets did not work for me, so I decided to reset my router (Verizon Fios) to factory settings and voila, everything is working great now.  So, if you are told to reset your TV or Roku device, you may want to consider resetting the router if all else fails.  It wasn't a big deal for me.  I just reconfigured the router wifi with the same SSIDs and password and everything reconnected automatically. 

Good luck

0 Kudos