Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jessy9
Level 7

Wifi connection/not connecting/through app and remote

Noticed about last week or so roku is not connecting to any wifi in the house. It says connection is excellent, but says it cannot be found. Every other device in my house is connected just fine to my wifi. I have 3 roku boxes, i have tried all 3 on each tv in my house. None have worked. I’ve tried to reset them unplug them all switch then all. Nothing works.   None are registering jn my app either. Does anyone know what is going on?! This is absolutely ridiculous that i cannot watch tv. 

0 Kudos
3 REPLIES 3
renojim
Community Streaming Expert

Re: Wifi connection/not connecting/through app and remote

Do you have Comcast/Xfinity or Cox as your ISP?  If so, change the wireless mode to b/g/n from g/n.                                        

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
jessy9
Level 7

Re: Wifi connection/not connecting/through app and remote

Yes i have Comcast, how do i do that? Wireless mode where on my roku in settings? Or my wifi settings?

0 Kudos
atc98092
Community Streaming Expert

Re: Wifi connection/not connecting/through app and remote

I just switched to Comcast two days ago, so I can now walk through the settings available. First, you won't find the setting on the phone app. You must log into the router via the web interface. Next, you must go to Gateway > Connection > Wi-Fi. Now, click on Edit for your 2.4 GHz radio. Right under the SSID is the Mode box. I see mine is set to G/N. Since none of my Roku players are connecting directly to this router, it hasn't been an issue for me. I have other access points on my network.

Now just change the Mode to B/G/N. However, if your router is configured like mine, you can't actually change it yourself. Comcast is controlling that setting, so you will have to contact them to get it changed. They seem to think they know better than you do how to configure your router. While that might be true in some cases, they really should permit the end user to make changes like this. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.